WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache » [Plugin: WP Super Cache] Don't cache pages for known users.

[Plugin: WP Super Cache] Don't cache pages for known users.

Viewing 4 replies - 1 through 4 (of 4 total)
  • i have the below settings:
    ***Don’t cache pages for known users – Checked
    *** Make known users anonymous so they’re served supercached static files. – Unchecked

    i want to change to
    ***Don’t cache pages for known users – Unchecked
    *** Make known users anonymous so they’re served supercached static files. – Checked

    When i ‘unchecked’ the #1, no problem, it is saved. but when i ‘checked’ #2; it is giving “Gateway Timeout” error or “404 error”. i know this will happen when long process is running? What is process triggered when i check this action?

    Actually i want see all the users same content.

    Plugin Author Donncha O Caoimh

    @donncha

    Adam Capriola – you don’t want to cache pages for known users because they need personalised cache pages so nobody else can be served those files.

    No, those options aren’t the same. The first one serves pages that anonymous users see on your site. The second does what it says. It doesn’t cache pages for those users.

    southdreamz – I presume you have a lot of logged in users or users who have a cookie set from something on your site and it could be creating lots of legacy cache files. Did you try the debug system in the plugin?

    Thanks @donncha O Caoimh.

    No, I don’t have any users’ specific features.
    Yes, I have lot of “legacy cache files”, around ~14,000 files.

    I try to save the page 4 or 5 times then it works. after updating to above setting, there are very less “legacy cache files” files

    Once again thanks.

    @donncha: Hi!

    In my scenario i DO want to serve the same cached page to known users as i do to anonymous users.

    The part that is personalized, i’ll load via an async AJAX call.
    And pages that i don’t want to cache at all, i’ll use DONOTCACHEPAGE.

    The ‘Make known users anonymous’ doesn’t do the trick for me. I don’t want to make them anonymous, i just want to serve the same page.

    Any chance that serving the same page to anonymous and known users will be in a future release?

    Best,
    Richard

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WP Super Cache] Don't cache pages for known users.’ is closed to new replies.
Skip to toolbar