The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

WP Super Cache
Delete Cache Button broken in Admin Bar (6 posts)

  1. Delete Me
    Posted 4 years ago #

    The "Delete Cache" link that shows in the admin bar for WP 3.3 does not work, clicking simply refreshes the page. If I click the "delete cache" buttons on the settings page it works fine though, so it's just the one in the new admin bar that has this issue.


  2. Donncha O Caoimh
    Plugin Author

    Posted 4 years ago #

    Odd. It works ok for me using the development version (and this part of the code hasn't changed since 1.0)

    I tried it on my homepage and a post. Can you edit the code in wp-cache.php and try debugging it?

  3. Delete Me
    Posted 4 years ago #

    Hmmm, how should I edit the code to test it though?

    I enabled my tool bar so it shows up everywhere (instead of just admin) but the delete button still doesn't work. Tried this on Chrome and Firefox 8.0. Weird.

  4. Donncha O Caoimh
    Plugin Author

    Posted 4 years ago #

    I made some changes to the dev version this morning. Is it still broken?

  5. Delete Me
    Posted 4 years ago #

    Had to migrate to a new host so i haven't reactivated Super Cache yet. Will reinstall later today and report back the results. :-)

  6. Delete Me
    Posted 4 years ago #

    Still broken, it refuses to delete the cache of the page I'm on, or any cache at all when I'm in admin. Other delete options work fine, including the settings page where I can click and view the current list of caches and delete them individually. A link like this on the list of caches works fine:


    This is the copied link the delete button of the same cache file that remains broken:


    I don't know if it's related, but when I see the list of cache files, it has a trailing slash (e.g. blahblahblah.com/blah/. My permalinks don't use trailing slashes though. (e.g. blahblahblah.com/blah )

    I can't see this being a permissions issue, as the old delete options work fine, it's just the delte button in the admin bar that remains broken.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic