WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache » [Resolved] [Plugin: WP Super Cache] Cutting / compressing excerpts – need help!

[Resolved] [Plugin: WP Super Cache] Cutting / compressing excerpts – need help!

  • Hi,

    sorry to bother, but after trying out WP Super Cache my blog is somewhat “blasted”… Now, all of the excerpts are being stripped after some 40 chars followed by “[…]”! It happened after I set (in addition to a manual .htaccess-rule, see below) the internal Super Cache compression to “on”. Thereafter my excerpts were stripped.

    This is what my .htaccess reads:

    # Expire images header
    ExpiresActive On
    ExpiresDefault A0
    ExpiresByType image/gif A2592000
    ExpiresByType image/png A2592000
    ExpiresByType image/jpg A2592000
    ExpiresByType image/jpeg A2592000
    ExpiresByType image/ico A2592000
    ExpiresByType text/css A2592000
    ExpiresByType text/javascript A2592000
    
    # gzip workaround for 1&1 hosting
    RewriteRule (.*)\.(css|js|xml|txt|htm|html)$ /media.php?file=$1.$2 [L]
    
    # kill them etags
    FileETag none
    
    # basic wordpress rewrite following dashboard settings
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    
    # force use of php5
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    
    # protect the htaccess file
    <files .htaccess>
    order allow,deny
    deny from all
    </files>
    
    # disable the server signature
    ServerSignature Off
    
    # limit file uploads to 10mb
    LimitRequestBody 10240000
    
    # protect wpconfig.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    
    # disable directory browsing
    Options All -Indexes
    
    # manual caching - force use of browser cache
    FileETag MTime Size
    <ifmodule mod_expires.c>
      <filesmatch "\.(jpg|gif|png|css|js)$">
           ExpiresActive on
           ExpiresDefault "access plus 1 year"
       </filesmatch>
    </ifmodule>
    
    # deny comment posting to no referrer requests
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*mediatribune.de.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]

    I have uninstalled WP Super Cache as instructed, stripped the inserted .htaccess-informations, deleted cache-directories, etc. with no use at all.

    I also un-commented some .htaccess-rules of which I thought they might be conflicting in some way, namely

  • # manual caching – force use of browser cache
  • # gzip workaround for 1&1 hosting
  • # Expire images header
  • Also deleted my caches (as prompted after unistalling WP Super Cache in WordPress), tried it our with Safari (otherwise using Firefox), editing the excerpts and even publishing new posts > Every time now there is a somewhat automatted “cutting” happening, which I never setup.

    (Oboviously) I am no pro, please help!

    http://wordpress.org/extend/plugins/wp-super-cache/

Viewing 1 replies (of 1 total)
  • Update:

    Strangely enough this has been solved by deaktivating the Flattr-Plugin. Didn’t cause any troubles beforehand but was the source of weird excerpt-abbreviations and “[…]”-inserts…

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] [Plugin: WP Super Cache] Cutting / compressing excerpts – need help!’ is closed to new replies.
Skip to toolbar