Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] Custom Post Type "listing" (archive-like) pages not getting updat

  • Tevya


    I’m using WP Super Cache on Multisite. One of the sites we’ve added a custom post type for “Horses.” We then have a couple of page templates that list all the horses according to certain categories. See the pages here: & here:

    The rest of the site seems to update the cache normally. However, when new horses (custom post types) are added, these pages don’t get updated. They’ll sit for days without the cache refreshing. Even clicking the button to delete the cache for that site doesn’t seem to help. The only way I’ve found to get them to refresh is to FTP into the site and delete the folders for this particular site in the cache/ blogs & supercache folders. Any ideas why?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Donncha O Caoimh


    That’s really odd. I don’t use custom post types so I can’t currently test this but it would help if you enabled debugging and tried to delete the cache. Don’t paste the log here but examine it yourself.

    Have you tried enabling “Clear all cache files when a post or page is published or updated” on the advanced settings page?



    I think I had tried that. The problem is I don’t want that happening across the network. And if I understand correctly, I can’t just turn that option on for this one site. I may try again, just to see, but without per-site settings, I’m not sure that would be a good thing.



    I just tried that, enabling both the extra home page checks and clear all cache files when…..

    Now that I’ve had more time to play with this, it appears it’s not something to do with custom post types. It’s as if the “delete cache” button isn’t doing anything on my Multisite. I can click it on a blog several times, then go load it in an incognito browser or an entirely new browser, and the old, cached page/post/custom post/etc still shows up, unchanged with my latest updates. This happened before, and still happens after having updated those 2 settings. Any ideas what’s going on? It seems deleting those folders is the only way to get it to update the cache. Thanks.

    Same problem here: Custom Post Type Archive is not getting deleted.
    Tevya, did you managed to resolve?


    The updated version seems somewhat better. Clicking the delete cache button twice will usually actually delete it. Though I’ve still had an instance or two where I’ve had to manually delete via FTP.

    Instead I’ve setup a cron job with a “rm -rf” command.
    I hope that Donncha can help on that.


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP Super Cache] Custom Post Type "listing" (archive-like) pages not getting updat’ is closed to new replies.