Support » Plugins » [Plugin: WP Super Cache] Comments do not show on pages

  • Despite everything I’ve tried, comments do not cause super-cached pages to update. As a logged-in user, I can see the new pages, so legacy cache is fine, but if I go in with a different browser as an unrecognized user, I see an old page without the comments. For hours and hours and hours. I’ve had several users tell me that they have the same problem, including at least one commentator who should be a recognized user, but is using firefox on linux.

    I have this same problem whether I use mod_rewrite or the PHP version (with the rewrite .htaccess code manually deleted).

    The one oddity about my site is that it is actually located at [url]/site rather than at just [url]. This is not visible to the user, as I use the redirection plugin ( I am also hosted at Dreamhost on a VPS, but not using the “tmp” hack recommended on an earlier support thread. (I wasn’t able to follow the documentation — would I need to change the .htaccess code too?).

    Although I’ve played around with a lot of options, my current settings are:

    Under “Advanced”
    * Use PHP
    * Compress pages
    * 304 Not modified
    * Cache rebuild [But note that my comment problem persists for over a day at a time]
    * Moible device suppport [and comments on the mobile version work fine, as I’ve listed many many mobile user types as ‘Rejected User Agents’]
    * Extra homepage checks
    * List newest cached files

    Cache timeout 7200 seconds
    Scheduler timer 600 seconds

    Do not cache feeds

    And a long list of rejected users agents for cell phones.

    Under “Preload” I checked “preload mode”. I have also tried unchecking it. I’ve tried various Refresh intervals from 720 up to 14400 minutes.

    I have a large site, but most pages are old don’t get comments, so I what I want is to create a large library of static files for them, and just have the pages update when a comment comes in — which is not that frequent, and usually only on the more recent pages. But I do want the pages with comments to reflect them.

    Daily traffic at is in the 500-1000 range at present.

  • The topic ‘[Plugin: WP Super Cache] Comments do not show on pages’ is closed to new replies.