WordPress.org

Forums

WP Super Cache
Category page is not updated when new Post is added (7 posts)

  1. awhig
    Member
    Posted 3 years ago #

    Hi,

    I noticed that my Category pages were out of date last week. April 18. I then manually deleted my whole cache. This fixed the problem.

    I then checked today, and saw that my Category pages were again out of date. WP Super Cache is serving the pages generated on April 18. We've had several new posts in this category, so I would assume they should have been updated.

    I believe when I first setup WP, this was all working properly. I would also assume, this would be a default behavior for WP, clear the category cache file, when a new post is added to that category.

    Am I missing something?

    I do not want to check "Clear all cache files when a post or page is published or updated.", as I think this will clear all files, including single entries, which I don't want.

    Please help.

    Thanks,
    Rich

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. awhig
    Member
    Posted 3 years ago #

    Follow up info...

    Some More Info: I see on my Advanced tab:

    Expiry Time & Garbage Collection

    Current server time is: 2012-04-25 18:23:40

    Warning! PRELOAD MODE activated. Supercache files will not be deleted regardless of age.

    On the Preload tab, currently I have Preload All, set and Refresh preloaded cache files every minutes, is set to 0.

    The reason I've set this to 0, is because I believed Category pages would be updated, if a new post was added to the Category. Please correct me if I'm wrong.

    Thanks for any help,
    Rich

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Unfortunately you'll have to enable the option that clears out all cache files. The plugin doesn't yet delete archive pages. I wish it did but I don't have time to add that feature. Maybe someone will submit a patch doing just that...

  4. awhig
    Member
    Posted 3 years ago #

    HI Donncha, thanks for the reply.

    So, in order to mitigate this issue, I've put on the preload panel...

    Refresh preloaded cache files every set to 720 minutes.

    and Preload all posts.

    I believe, my cached pages, should never bee older than 720 minutes then?

    I'm still having issues, with the category and index 2, index 3, etc. pages. When I view source, they are showing:

    <!-- Cached page generated by WP-Super-Cache on 2012-05-09 12:12:50 -->

    Today is 5-15-2012. My pages are outdated, and content that has been pushed off the home page, are no longer showing up anywhere, as the pages, have not been re-generated for 6 days.

    How do I fix this?

    Some more info, on the Advanced tab, I have Cache timeout set to 3600.
    Scheduler set to Clock 00:00
    Interval hourly.

    Also, I'm showing the warning below. Can you tell me what a Supercache file is? Should I turn off preload mode? Is this the issue?

    Thanks for any help.
    Rich

    Warning! PRELOAD MODE activated. Supercache files will not be deleted regardless of age.

  5. awhig
    Member
    Posted 3 years ago #

    I'm still trying to figure this out. I have 5 sites and they are all having problems with cached category and index pages not being re-generated.

    All of them have 3600 seconds as the cache timeout, and most of them had the garbage collection set to clock 00:00, hourly (1 was set to timer 3600). I believe, my issue is with the cache timeout. It is not properly throwing out cached category and index pages, correct? I guess I don't have to fiddle with the garbage collection settings, as that is not my main issue (that I know of).

    I do not think this is related to preloading, as Preloading, only caches individual post and pages, correct?

    I tried turning on debugging, but didn't see anything relevant. I then changed the gc timer to 10 seconds, and kept checking the debug log, but never saw anything. If I change the cache timeout to 60 secs from its current 3600, and then revisit a category page, it finally regenerates it (It was last generate 4-27-2012). I then put back the cache timeout to 3600 and the timer back to 3600 (I guess).

    I'm hoping by updating these options, I'll jiggle something to cause everything to update properly...

    I'm at a loss on how to get this to work correctly.

    Thanks,
    Rich

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Have you tried disabling the preload completely?

  7. awhig
    Member
    Posted 3 years ago #

    Yes, I disabled it on a few of them as a test. I just checked, and I'm still seeing a cached category page, that says

    <!-- Dynamic page generated in 0.243 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2012-05-15 15:39:40 -->
    <!-- Compression = gzip -->

    My cache timeout is set to 3600 seconds, so I would assume this should have already been regenerated...

    Scheduler is set to Clock 00:00, if that matters.

    At this rate, I'm going to have to manually delete the cache every day, on all my sites, in order to have up-to-date category and index pages...

    Please help.

    Thanks,
    Rich

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic