WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache » [Plugin: WP Super Cache] Can't login with late init

[Plugin: WP Super Cache] Can't login with late init

  • Hello.

    WP is installed in directory /wordpress/.
    When $wp_super_cache_late_init is set to 1 I can’t login dashboard. Use PHP mode and no rules in .htaccess. When I try to login, system redirect me to /wordpress/wp-login.php and show home page. I notice no errors on this page.
    I can login when legacy caching mode is on or when $wp_super_cache_late_init is set to 0.
    What should I do to use PHP mode withous login problems?

    http://wordpress.org/extend/plugins/wp-super-cache/

Viewing 15 replies - 1 through 15 (of 24 total)
  • I’ve just started seeing this also.
    Driving me nuts!!

    I’m actually using mod_rewrite and this is still happening.

    Donncha, what’s the latest on this ?

    Plugin Author Donncha O Caoimh

    @donncha

    nisiwi – unfortunately I’ve never had time to debug this problem. I don’t know why it’s happening.

    yeah, just realised that its only happening on 1 site – very odd so its not a WP Super Cache issue

    must be a WP issues somewhere

    Think I may have found the problem.

    Late ini in mod_rewrite mode was problematic, causing the loop.

    However when switching to PHP mode I was expecting it to resolve the problem, which it didn’t.

    On inspecting the htaccess file I noticed that all mod_rewrite rules were still in tact with PHP mode enabled.

    After stripping out the htaccess rules from mod_rewrite mode the problem was resolved. I can log in without the strange looping back to the front page.

    Odd, while this worked for one site I’m seeing the same problem and this fix doesn’t resolve it.

    When WP Super Cache is disabled all is fine, when enabled even just by itself I get this problem ?

    Will try some more plugin configs to see if that’s it.

    No matter what configuration of plugins I have, even with all plugins disabled as soon as late ini is enabled in WP Super Cache the site login jumps to front page with no dashboard or bar, failing to log in ?

    I was forced to switch to W3 Total Cache and the problem resolved.

    And I’m back to WP Super Cache – W3TC doesn’t have the PHP options I need.

    Will have to work out what’s causing this with some experimenting.

    Plugin Author Donncha O Caoimh

    @donncha

    I think you’ll need to debug the WordPress login code. I don’t know why this is happening to your site, sorry!

    Having exactly the same issue here! When I fill out and submit the login form, I just get redirected to mysite.com/login.php but nothing happens. If I set wp_super_cache_late_init to 0 all is good again. Using latest version of WPSuperCache in PHP mode.

    So any updates on this?

    Plugin Author Donncha O Caoimh

    @donncha

    floz – none, can you try debugging this? Use the plugin debugger and you might need to use error_log() in wp-login.php and the login code in wp-includes/

    @donncha: Tried debugging, but everything looks fine, no error messages. Narrowed it down a tiny bit: If I manually rm -rf the wp-content/cache/supercache/www.mydomain.com folder, then it works all well, and I can log in correctly. But if I then log out, and try to log in again, I have that direct redirct to the home page problem (when trying to post a comment, I get shot directly to the home page, and the comment is not posted)…

    it happed to me now, don’t know how to fix it.

    happening again with another site

    I don’t know if this will help you or not, I was just having the same problem, I disabled Make known users anonymous so they’re served supercached static files. Now everything works as intended.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: WP Super Cache] Can't login with late init’ is closed to new replies.
Skip to toolbar