Support » Plugins » [Plugin: WP Super Cache] Caching, yet not caching?

  • My blog is caching, yet still querying the database. I used two plugins to track this, and they both show the same info:

    Cache Hits: 1232
    Cache Misses: 212
    DB Queries: 45

    The number of DB queries is the same whether WP Super Cache is running or not. Pages are being cached, everything seems to be working right, yet the database is still being hit as usual. Page load times are the same with WP Super Cache enabled or disabled.

    As they say, “What the heck?” Any idea what’s up?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Sounds like either the cache isn’t working, or most of your hits are once off hits that don’t take advantage of cached pages.

    Do you see the supercache comment at the end of each page if you visit as an anonymous user?


    First of all, thank you for your plugin and for picking up the WP-Cache ball.

    Here’s what it says:

    41 queries.
    1.996 seconds.
    <!-- Dynamic Page Served (once) in 1.995 seconds -->
    <!-- super cache -->

    I guess I’m not understanding how the cache is working. Part of it seems to be working, but then again, it’s not serving static pages.

    BTW, that stat above is for my main page, so it’s not a once-off hit.


    That file is a static file. Look in wp-content/cache/supercache/your/url/here/index.html and you’ll find your page content.


    If that’s a static file with 41 queries, then I’m utterly stumped as to what WP-Supercache is giving me, since it’s 40-45 queries whether the plugin is loaded or not. I’m not seeing any speed benefits, either.

    In the past, WP-Cache and some of its derivatives would load up a page for me with about 6 queries in about a half second. I could actually see a major speed boost. Now I can’t.

    So, like I said, I guess I’m stumped at how WP-Supercache is helping me at all.


    The 41 queries are generated elsewhere. All you’re seeing is the report. The report is cached as a static file along with everything else on the page.

    Look at your plugins. Those queries are coming from somewhere. Also, install an object-cache. That will help a lot.


    Since object caching was removed in WordPress 2.5, the only way to restore it that I have seen is through a plugin from NeoSmart. I was using that plugin, but it causes errors in WP-Supercache, so I disabled it.

    If you know of another plugin or method for restoring object caching, I’d love to know what it is. I was hoping that WP-Supercache would provide some of this functionality.


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP Super Cache] Caching, yet not caching?’ is closed to new replies.