Support » Plugin: WP Super Cache » [Plugin: WP Super Cache] cache = wrong fonts displayed?!

  • Got a weird one here:

    2 of my sites (I run over 100 sites in a WP MS setup) will not serve/display the proper FONT when caching is enabled. Other sites using the same exact template render it fine (these sites all use the same plugins).

    • If caching is turned off, the fonts render properly.
    • If domain mapping is disabled for that domain, the fonts render properly (I have the domain mapping plugin support enabled in the plugnis tab on the WPSC settings menu.. FYI the bad behavior radial wont save/stick to the ‘disabled’ position)
    • No caching setting (except off) seems to fix it
    • This only happens on Firefox.
    • …and it’s only happening from fonts referenced in my CSS using this font-face:
    @font-face {
    	font-family: 'ufcomwebh';
    	src: url('fonts/ufcomwebh.eot');
    	src: local('☺'), url('fonts/ufcomwebh.woff') format('woff'), url('fonts/ufcomwebh.ttf') format('truetype'), url('fonts/ufcomwebh.svg#webfont') format('svg');
    	font-weight: normal;
    	font-style: normal;

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Donncha O Caoimh


    Should you add a “/” at the start of the fonts url? I’m only guessing as caching shouldn’t do anything to the stylesheet and rendering!

    It’s a relative URL. The fonts dir. sits in the theme’s directory.

    Mind you, this was working fine for months on end on 100% of my sites, and it still works for most sites (even when caching is turned on). It’s just something is causing a conflict on 2 of these sites, when using domain mapping + WPSC.

    I cant believe caching could affect this.. it’s so bizarre! I’m pulling my hair out trying to figure out what’s unique about these 2 sites.

    If I disable domain mapping, or caching, the fonts render properly

    Plugin Author Donncha O Caoimh


    Checked your error logs for 404 errors? Perhaps the fonts aren’t being served correctly?

    Error logs are clean — whatever it is, it isnt throwing an error.

    Mind you, the fonts get served in Safari and IE — just not FF.

    …found more odd behavior on another site.

    When caching is enabled, the includes to my CSS files suddenly have HTTPS:// (SSL) on them.

    This is just beyond bizarre. There is nothing anywhere referencing https:// for this site… especially not in it’s theme.

    Just bumping this to say I have disabled the plugin. I haven’t been able to isolate the cause of this, but can see Domain Mapping / Caching might not be playing nice with each other on this new server.

    It’s more important to keep Domain Mapping running than it is to provide caching.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP Super Cache] cache = wrong fonts displayed?!’ is closed to new replies.