WordPress.org

Forums

WP Super Cache
cache tests failing (20 posts)

  1. stuart.thompson83@ntlworld.com
    Member
    Posted 4 years ago #

    We are using wp-super-cache and it seems to be helping our site load a bit faster but we are testing errors or “fails” with the “Test Cache” in the “Tester & Contents” tab of this plug-in.
    Please see the report below. Does this mean the site is working fine or a problem needs resolving?
    Please note that we are also testing the cache using a third part tool from http://www.seositecheckup.com/ - this tool is also reporting that the caching is not operating.

    “Test Cache” in the “Tester & Contents” report:
    Cache Tester
    Test your cached website by clicking the test button below.
    Fetching http://www.viseum.co.uk/ to prime cache: OK
    Fetching first copy of http://www.viseum.co.uk/: OK
    Fetching second copy of http://www.viseum.co.uk/: OK
    One or more page requests failed:
    • Page 1: 0 ()
    • Page 2: 0 ()
    The pages do not match! Timestamps differ or were not found!

    Cache Contents
    Cache stats are not automatically generated. You must click the link below to regenerate the stats on this page.
    Regenerate cache stats
    Cache stats last generated: 1,335 minutes ago.
    WP-Cache (195.94KB)
    • 31 Cached Pages
    • 0 Expired Pages
    WP-Super-Cache (62.15KB)
    • 2 Cached Pages
    • 0 Expired Pages
    List all cached files
    Garbage Collection
    Last GC was 08:14 minutes ago
    Next GC in 01:46 minutes
    Expired files are files older than 3600 seconds. They are still used by the plugin and are deleted periodically.

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Try the development version of WP Super Cache on the plugin download page as it saves each page when it does the test so you can compare them manually.

  3. stuart.thompson83@ntlworld.com
    Member
    Posted 4 years ago #

    Thanks.
    We have loaded this version of super-cache and the error messages no longer appear:)
    However!! For absolute clarirty these messages were:
    Fetching http://www.viseum.co.uk/ to prime cache: OK
    Fetching first copy of http://www.viseum.co.uk/: OK
    Fetching second copy of http://www.viseum.co.uk/: OK
    One or more page requests failed:
    • Page 1: 0 ()
    • Page 2: 0 ()
    The pages do not match! Timestamps differ or were not found!

    So, with the development version of wp-super-cache these errors are no longer reported but the symptom still persists ie the when visiting the website for the first time,it seems like the server was asleep and needs waking up before pages start to load quickly!

    Therefore could the orgigonal reported problem still be to blame? ie "One or more page requests failed"

  4. stuart.thompson83@ntlworld.com
    Member
    Posted 4 years ago #

    a quick question - can we use this development version of super-cache for general operation? or should we reinstall the non development version?

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Currently you can and it's nearing release of a new version so when a new version comes out you'll still be notified of the upgrade.

    You should probably try the debug system in the plugin to figure out why it's not caching. Log to a file, not email.

  6. larssonk22
    Member
    Posted 4 years ago #

    Hi donncha, do you know what it means by

    (taken from Stuart's post above)

    One or more page requests failed:
    • Page 1: 0 ()
    • Page 2: 0 ()
    The pages do not match! Timestamps differ or were not found!

    I was wondering if the slideshow could be the cause, since it changes every few seconds with written content within it aswell.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    The error returned from wp_remote_get() isn't in the form it's supposed to be. I don't know why. You could edit wp-cache.php and around line 908 (of version 0.9.9.8 released today) add this code:

    var_dump( $page ); var_dump( $page2 );

    That will tell you what exactly what was returned by the cache tester.

  8. larssonk22
    Member
    Posted 4 years ago #

    I got the following, not sure what it means

    array(4) { ["headers"]=> array(0) { } ["body"]=> string(0) "" ["response"]=> array(2) { ["code"]=> int(0) ["message"]=> string(0) "" } ["cookies"]=> array(0) { } } array(4) { ["headers"]=> array(0) { } ["body"]=> string(0) "" ["response"]=> array(2) { ["code"]=> int(0) ["message"]=> string(0) "" } ["cookies"]=> array(0) { } }

  9. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Thanks, that's bizarre. That should be filled with error messages. I'm not sure why that's happening for you. Test it manually by reloading the homepage I guess.

  10. larssonk22
    Member
    Posted 4 years ago #

    The site is being cached we've used seositecheckup website to confirm this. We're just concerned about the severity of this error.

  11. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    You probably don't need to worry about it but if you are worried you'll have to debug wp_remote_get() to figure out why that's breaking :(

  12. William Bowles
    Member
    Posted 4 years ago #

    I'm using V 0.9.9.8 and got this when i tested the cache:

    Test your cached website by clicking the test button below.

    Fetching http://www.creative-i.info/ to prime cache: OK
    Fetching first copy of http://www.creative-i.info/: OK (1.html)
    Fetching second copy of http://www.creative-i.info/: OK (2.html)
    The pages do not match! Timestamps differ or were not found!

  13. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Creative-i - click on 1.html and 2.html and compare them manually. That might give you a clue as to why the test failed.

  14. William Bowles
    Member
    Posted 4 years ago #

    I just did a test on the SEO site mentioned above and it appears that pages are not being cached, yet there's nothing on the WPC page that indicates that it's not caching:

    'It does not appear that you are caching your pages.'

    And in-advertantly coughed up another problem with an Amazon/Google/Alexa search api?

  15. William Bowles
    Member
    Posted 4 years ago #

    Donncha:

    Both pages look identical but if I'm not caching the pages?

    B

  16. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    I looked at your site and it looks like Supercache isn't turned on at all. There's no Supercache comment at the end. Perhaps use the debug system in the plugin to figure out what's going wrong?

  17. William Bowles
    Member
    Posted 4 years ago #

    I just checked the dot htaccess file and it seems ok but when I did a refresh:

    Mod Rewrite Rules
    Mod Rewrite rules cannot be updated!

    here's the file (I had the wpcache code first and changed it, made no dif, it kept telling me that it was missing # BEGIN WordPress):

    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz" [L]

    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html" [L]
    </IfModule>
    # END WPSuperCache

  18. William Bowles
    Member
    Posted 4 years ago #

    Debug won't work cos the mod rewrite rules don't work, yet I've done everything according to the instructions. .htaccess is in the root directory, it has all the right code in it but WPC just won't recognize it.

  19. William Bowles
    Member
    Posted 4 years ago #

    Y'know the setup is extremely confusing!

    I get this on the advanced page:

    The rewrite rules required by this plugin have changed or are missing. Scroll down the Advanced Settings page and click the Update Mod_Rewrite Rules button.

    But there IS NO button.

  20. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Weird, it should be there. You could just try PHP mode caching, it's 99.99999% as fast most of the time and a lot less hassle to setup. That's what is configured when you turn caching on on the Easy settings page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic