WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Super Cache] after update 0.9.2 server resources doubled

[Plugin: WP Super Cache] after update 0.9.2 server resources doubled

  • Hi,

    Updated yesterday to super cache version 0.9.2 from 0.9.1 .

    Server resources doubled after the first 18 hours after the update..

    See screenshot: http://img12.imagevenue.com/img.php?image=29095_1_122_373lo.JPG

    CPU doubled, overal serverload doubled as well.

    Wp super cache is working normally as usually, cached pages are created and the normal msg in the footer is present like always.
    I use super cache on mode half on.

    What do I have to check to find the issue? Since this cant be normal.

Viewing 15 replies - 1 through 15 (of 40 total)
  • additional info:

    <!– Dynamic page generated in 1.870 seconds. –>
    <!– Cached page generated by WP-Super-Cache on 2009-03-29 13:27:06 –>
    <!– Compression = gzip –>

    HALF ON Super Cache Disabled, only legacy WP-Cache caching.

    after 1 minute:
    Cache Contents

    WP-Cache

    * 18 Cached Pages

    Expiry Time & Garbage Collection
    Expire time: 10800 seconds

    all settings have been the same for ages 😉

    Did a manually install, and now the cache seems to affect the server resources back to normal.. server load dropped to 0.26 after only 15 minutes…

    So better to not use the automatically installer next time I guess.

    The same happened here! Something’s very wrong with 0.9.2.

    Two of my sites going down after installing 0.9.2 and now the server has ‘died’.

    I wonder if this is a problem with the automatic installer not being able to update the files in wp-content, not sure. Since I don’t have the time to investigate, just went back to 0.9.1 (manual install) to be safe.
    Everything is back to normal now. Whew, server alive again.

    Same thing happened to me. My site is down. If I reboot the server, it stays up for about ten minutes and then goes down again. The only thing I have done is the last 48 hours is the update.

    I think I’ve fixed this. Grab http://svn.wp-plugins.org/wp-super-cache/trunk/wp-cache-phase1.php and put it in your plugins/wp-super-cache/ folder, overwriting the original file.

    Then when your site comes up again clear your cache. Please post here if that fixes it.

    michaelhyatt: your server went down probably because of to many server resources being used? – you can also install 0.9.2 and delete the cache and manually turn super cache on and off a few times. That also seems to do the trick.

    I think I’m going to stick with 9.1 for a while. I didn’t try the suggested fix. I just don’t have the time to play with this right now. 9.1 seems to be working fine. Thanks.

    loller6661 – you’re right. the problem was with a fix for the way PHP kills off objects during shutdown. I changed the “meta” object to an array to avoid this.
    Unfortunately cached files generated by earlier versions of the plugin had the objects cached so I just added an array check to avoid problems.

    michaelhyatt – Turn caching off on the admin page, delete the cache, and then upgrade. It’ll work then. Sorry you had problems.

    0.9.2 is especially important if you’re running a shiny new version of PHP5.

    Donncha, I replaced that file as you suggested a few replies above, and my site seems to be doing better now. It kept going down all day, I had to keep rebooting the server, restarting Apache didn’t seem to do much.

    raoulpop – glad to hear it!

    Something I forgot to add to the topic:

    donncha thanks for making wp plugins and support users 😉

    My server’s down again. Time to disable the plugin and go without it for now. Sorry Donncha, but 5 outages in one day is a lot to take.

    It’s curious, the two blogs that had problems, now go OK with 0.9.1, but the rest that worked fine with 0.9.2, now don’t work, nor depugrading to 0.9.1. I’ve had to disable the plugin in those.

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘[Plugin: WP Super Cache] after update 0.9.2 server resources doubled’ is closed to new replies.
Skip to toolbar