WordPress.org

Forums

WP Super Cache
Admin Bar caching (3 posts)

  1. Hal
    Member
    Posted 3 years ago #

    I cannot for the life of me make the wpadminbar not cached. I am using version 1.0 of WSC, with caching in php mode, and no caching for known users.

    If a logged in user gets to any page first, the admin bar is cached and everybody else sees it. I am testing this in different browsers (one logged in and one not), and am sure that's the case.

    I've tried adding a dynamic-cached-content section to detect a logged in user, to work around this, setting $wp_super_cache_last_init, but that does not work. At least not in my usage.

    I suspect I am probably missing something very simple, but sure can't see it what it is.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Hal
    Member
    Posted 3 years ago #

    I just realized that while I have the 'don't cache pages for known users' option checked, I am still getting cached pages, judging by the output at the very bottom of the raw source, when logged in as an administrator. Maybe that's an issue?

    <!-- Cached page generated by WP-Super-Cache on 2012-05-21 17:46:45 -->

  3. Hal
    Member
    Posted 3 years ago #

    OK, this is cookie related. WordPress allows user definable cookie names for things like wordpress_logged_in_*. In this case, the user defined stuff was not agreeing with super cache.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.