WP Super Cache
Adding "files" to include directories erases subsite in image url (3 posts)

  1. warmthesoup
    Posted 3 years ago #

    I have a multisite subdirectory install. WP Cache is working awesome in every respect except one.

    I have a file say.


    I am trying to get WP Super Cache/Offlinker to include this file with a proper CDN url which does not happen with the default wp-content, wp-includes on a multisite.

    So after adding "files" to both (or either) include directories it erases "blogname" in image url but adds the proper CDN cname in the path resulting in url like this.


    So adding files to the include directory works, but elimates the blogname which creates a broken image. Anyway to accomplish this and keep the blogname in the url?

    Thank you.


  2. warmthesoup
    Posted 3 years ago #

    I did notice that

    When using origin pull and placing in the CDN fields for host and cnames:


    That the image path now becomes a working path like this


    However that duplicates all the other static js, css files in the header to also include the blogname in the CDN url.


    Has anyone successfully used Reg Ex (or Reg in combination with .htaccess) in the include directories in WP Super Cache and Offlinker include directories option so their subblog images get included. I'm trying to include


    in the include path so my media gets a CDN url too. Any feedback or help would be wonderful.

  3. wmark
    Posted 2 years ago #

    Multisite installations are only supported in the commercial version of CDN-Linker plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic