WordPress.org

Forums

[Plugin: WP Super Cache] 0 Cached Pages (52 posts)

  1. CharnaD
    Member
    Posted 5 years ago #

    I have several sites on WP 2.8.4. And i've recently found, that i have 0 cached pages everywhere. Plugins seems to work correctly, no error messages. I've reinstalled it like 10 times, changed WP version to 2.8.2, changed Super-Cache version to 0.8.9. Nothing changed. I still got

    WP-Cache
    0 Cached Pages
    0 Expired Pages

    WP-Super-Cache
    0 Cached Pages
    0 Expired Pages

    on 3 different sites on 3 different hosts. 2 shared and one VPS.

    Changed rules to 777 for wp-content, cache folder and everything that could be useful. Nothing changed.

    Did anyone encountered such an issue? Does anyone know what to do?

  2. saeidzebardast
    Member
    Posted 5 years ago #

    same problem!
    wp 2.8.4
    wsc 0.9.6.1

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Try the dev version on the download page. It has new debug code you can use to log what the plugin does.

  4. mickscool
    Member
    Posted 5 years ago #

    I am having the exact same issue with 2.8.4, any help anyone?

    I set it to "ON" but it automatically goes to "HALF-ON" and shows these stats below:

    Cache Contents

    WP-Cache (0KB)

    * 0 Cached Pages
    * 0 Expired Pages

    Garbage Collection
    Last GC was 43:02 minutes ago
    Next GC in 26:58 minutes

    I have searched the net, read the FAQs, reinstalled it and god knows what else ....

    I really want to use this plugin...

  5. mickscool
    Member
    Posted 5 years ago #

    I installed the development version and it keeps throwing these 4 lines in the cache/log file:

    22:27:48 /teams/ No wp-cache file exists or user agent rejected.
    22:27:48 /teams/ In WP Cache Phase 2
    22:27:48 /teams/ Setting up WordPress actions
    22:27:48 /teams/ not caching POST or non empty GET request.

    22:28:02 /feed No wp-cache file exists or user agent rejected.
    22:28:02 /feed In WP Cache Phase 2
    22:28:02 /feed Setting up WordPress actions
    22:28:02 /feed not caching POST or non empty GET request.

    Anyone, any clues?

  6. Nautipuss
    Member
    Posted 5 years ago #

    Check that you've not got the "GZIP Output" plugin installed.

    After trying to get WP Super Cache working for a few days with no apparent problems that I could see, disabling the GZIP Output plugin solved it instantly for me. As WP Super Cache includes compression anyway, the GZIP Output plugin is no longer required.

  7. Donncha O Caoimh
    Member
    Posted 5 years ago #

    mickscool - are you using proper permalinks or the ?p= format?

  8. mickscool
    Member
    Posted 5 years ago #

    Thanks Nautipuss and donncha,

    Nautipuss - I am not using GZIP output but I am using "PHP Speedy". I know that "PHP Speedy" and "WP-Super Cache" do not co-exist, so I removed "PHP Speedy" totally but still I was not able to work "WP Super Cache", and so I had no other options except to revert back to "PHP Speedy" till I get "WP Super Cache" working.

    Donncha - I am using permalinks and I know "WP Super Cache" won't work if I don't use permalinks. In addition, you can check my site here : http://tinyurl.com/b9cr2v

    Can you please help now?

    Thanks

  9. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Turn off gzip output, as the plugin will gzip cache files and serve the appropriate files. Delete php-speedy completely I guess and give supercache a go again. You could try the dev version (look at the "other versions" page at the end) which has a nice debugging system you should try.

  10. M
    Member
    Posted 5 years ago #

    Hi, I've been happily using your plugin for more then half a year now and believe me it was a real keeper!

    After the last update i saw the same thing described buy the other guys in my blog as well. 0 cached pages and tons of expired pages. and the collection times seem to be working strange. no other plugin conflicts.

    also, I checked the "is_archive" and "is_category" to be not cached. when i first go to the pages after logging out and after clearing the browser cache, i see the un-cached category. but 10 minutes later the page looks like it's been cached again and shows only one month old article.
    Any ideas will be much appreciated.

  11. Donncha O Caoimh
    Member
    Posted 5 years ago #

    infolegal - very odd, can you change your expiry time? Just in case it's gone wrong somehow.

    You could try the debug settings to investigate what the plugin is doing.

  12. M
    Member
    Posted 5 years ago #

    Sorry for the late reply. Problem still not solved. I'll try adding the new dev plugin and see how's that working.

  13. M
    Member
    Posted 5 years ago #

    I've set debugging level to 2. I got 30 messages in 2 minutes saying:
    URI rejected. Not Caching

    Disable these emails by commenting out or deleting the line containing $wp_cache_debug_email in wp-content/wp-cache-config.php on your server.

  14. Donncha O Caoimh
    Member
    Posted 5 years ago #

    ok, so now check the "Accepted Filenames & Rejected URIs" section of the admin page, specifically the first textarea, the list of rejected URIs. Mine is:

    wp-.*\.php

    but it might also have index\.php

    What does yours have?

  15. M
    Member
    Posted 5 years ago #

    It looks like it has:
    wp-.*\.php
    index\.php

    I have removed the index for now, and I'll let you know if it's still not working.

    Over night I got a lot of errors (around 900) saying something like this:
    rebuild_or_gc: rename to /home/infolega/public_html/wp-content/cache/supercache/www.domain.ro/cum-trebuie-facuta-o-reclamatie/2009/10/12/index.html.gz.needs-rebuild

    I have the "cache rebuild" option checked. Not sure if that is influencing the caching in any wrong way.

  16. M
    Member
    Posted 5 years ago #

    I have done the following:
    - delete the index\.php from the rejected URIs
    - unchecked the Cache rebuild
    - set the expiry time to 310 instead of 300 (this change was done yesterday)

    This morning, after the two changes i still get the following:
    - URI rejected. Not Caching
    - Anonymous user detected. Only creating Supercache file.

    I really appreciate you taking the time to answer.

  17. Donncha O Caoimh
    Member
    Posted 5 years ago #

    That's odd. Best thing to do now is dive into the code and debug it yourself. Look in wp-cache-phase2.php in the wp_cache_is_rejected() function. I'm afraid you'll just have to use error_log or wp_mail() to send you info when a request is made.

  18. mickscool
    Member
    Posted 5 years ago #

    I also tried everything but couldn't make it work.

    I deleted PHP speedy completely from my site.
    The gzip output if off
    permalinks is on
    I installed the latest version yesterday.
    I have turned on logging but no errors are being thrown and it shows 'WP Super Cache' as ON but still 0 pages cached as shown below:

    Cache Contents

    WP-Cache (0KB)

    * 0 Cached Pages
    * 0 Expired Pages

    WP-Super-Cache (0KB)

    * 0 Cached Pages
    * 0 Expired Pages

    Don't know how to fix this on my WP 2.8.4 installation.

    Thanks

  19. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Odd, the debug settings should have showed you why it wasn't working.

  20. Max Chirkov
    Member
    Posted 5 years ago #

    Same story here. Using version 0.9.7.
    Tried enabling email and file logging - neither worked. Didn't get any emails and the file that it says it's currently logging to not even being created. The wp-content/cache/ is chmoded to 777.

  21. mickscool
    Member
    Posted 5 years ago #

    My wp-content/cache folder is 755, could that be the issue?

    But I cannot change it to 777, I think because wp-supercache has created it because i see these folders under it:

    /blogs
    /meta
    /supercache
    .htaccess

  22. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Bizarre. Any plugins or themes using the output buffer? Look for the command ob_start() in your plugins and themes folders. Have you tried the plugin in half-on mode?

  23. Max Chirkov
    Member
    Posted 5 years ago #

    I have a plugin that uses output buffer. Can't disable it right now though, to try without it. Half-on mode doesn't work either.

  24. Donncha O Caoimh
    Member
    Posted 5 years ago #

    It probably is a plugin. I experienced the same 0 cached files problem when I activated the wp-minify plugin. It was a problem in wp-minify where the output buffer wasn't set up because of a bug in the theme. (Complicated eh?)

    Anyway, I fixed the problem in wp-minify and the author has been DMed so hopefully the next version will include the fix.

  25. Max Chirkov
    Member
    Posted 5 years ago #

    I'll try disabling it some time when traffic is low. I'm using output buffer to insert widgets within content areas via shortcodes. The 2.9 has this in the core, but earlier versions don't have this function.

    Will post the results.

  26. johnh10
    Member
    Posted 5 years ago #

    I haven't added any new plugins, but I did upgrade to the latest version of WordPress. Then Supercache stopped working except for feeds.

  27. saeidzebardast
    Member
    Posted 5 years ago #

    I found the solution:
    defined WP__CACHE before require_once(ABSPATH . 'wp-settings.php');

  28. Donncha O Caoimh
    Member
    Posted 5 years ago #

    saeidzebardast - the plugin should have printed an error message about that but I found an error in the logic that I have just fixed. Glad it was something simple!

  29. smoke489
    Member
    Posted 5 years ago #

    Hello, I have experienced the same problem as well. As per the solution recommended by saeidzebardast, will this fix be included in an update for the plugin or is this a change I would need to make manually? If so, where specifically would I make this change?

    Thank you!

  30. Donncha O Caoimh
    Member
    Posted 5 years ago #

    smoke489 - read the readme.txt that comes with the plugin. The WP_CACHE define is in your wp-config.php

Topic Closed

This topic has been closed to new replies.

About this Topic