Support » Plugin: WP Stripe » [Plugin: WP Stripe] Modal hangs in "transferring data" mode

  • Resolved essaysnark


    First off – love this plugin! So much so, that we wanted a way to donate for it but couldn’t find one. 🙁

    An issue arose today though. Have only used this for a few transactions, first one went fine. However, two today have resulted in duplicate transactions. The modal seems to hang for the user with “Transferring data from” in the bottom status bar. Here’s screenshot provided by a user:

    In both cases, we ended up with two payments (had to refund the second). Not sure if these users both clicked Submit Payment 2x?

    All three of these transactions were submitted from India – but the first one worked fine, these two people today had same problem. Could it be a latency issue of some sort? Any ideas?

    The payment form is live here in case you want to check it out:

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Noel Tock


    Human Made

    Hey there, really awkward. Do you have a live example somewhere? Cheers!

    Sure thing, the URL we posted previously should still work – the payment button is halfway down the page:

    Sorry just realized that we may have confused things. As you saw from the other thread (sorry for cross-posting! wasn’t sure of protocol) this could be a Chrome thing.

    We have two pages with seemingly same behavior:
    1) connected to our live Stripe keys and plugin ver 1.4.5
    2) connected to our test Stripe keys and plugin ver 1.4.6

    Thanks for looking into it!

    Plugin Author Noel Tock


    Human Made

    Hmmm, awkward. I tested and it hung for me too. There was a jQuery error in the console though. I also wasn’t able to replicate locally. Have you tried using the inline form? [wp-legacy-stripe]

    Thanks for checking it out Noel. Similar behavior with the inline version. Any hints on where we should be looking to investigate the jQuery error? I just tried deactivating all my plugins except for WP Stripe and am seeing the same behavior. Does that mean it might be our theme? Not a WP expert — any advice on where to start researching this problem on our site would be greatly appreciated!

    ETA: We’re on the Genesis framework in case that matters.

    Did you figure this out? I’m having the same problem.

    Nope never did.

    Bummer. Noel? Sorry to bug, but I’d really like to figure this out. Mine behaves mostly the same except that in my case it doesn’t appear that the transaction ever happens, no matter how many times it’s clicked on. Any ideas… anyone?

    Mine can be found at:

    I am seeing the same thing in chrome. I have tried disabled all plugins but still having the same “behavior” as both of you.

    Such a shame because this plugin is so beautiful, thank you Noel!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: WP Stripe] Modal hangs in "transferring data" mode’ is closed to new replies.