WordPress.org

Support

Support » Plugins and Hacks » WP Stripe » [Resolved] [Plugin: WP Stripe] Inline form [wp-legacy-stripe] not working in 1.4.0

[Resolved] [Plugin: WP Stripe] Inline form [wp-legacy-stripe] not working in 1.4.0

  • I ran into an error and tracked it down. It looks like using [wp-legacy-stripe] to get the form inline on the page (rather than in the iframe) does not work in 1.4.0.

    After hitting the submit button I would get a long pause and then an error message on the page: “There was an error processing your card” And in the browser’s error console:

    Error: ReferenceError: ajaxurl is not defined
    Source File: [domain omitted…]/wp-content/plugins/wp-stripe/js/wp-stripe.js?ver=3.4
    Line: 38

    I looked into this and it seems that the newer ajax code does not yet work with putting the form directly on the page via [wp-legacy-stripe].

    This is too bad because I like having the form on the page, and the iframe/pop-up is actually appearing *behind* my header in the default Twenty Eleven theme. (In that theme the header#branding CSS is set to z-index: 9999;)

    Cheers,
    -Paul

    http://wordpress.org/extend/plugins/wp-stripe/

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] [Plugin: WP Stripe] Inline form [wp-legacy-stripe] not working in 1.4.0’ is closed to new replies.
Skip to toolbar