WP Stripe
[resolved] Inline form [wp-legacy-stripe] not working in 1.4.0 (6 posts)

  1. PaulMorris
    Posted 4 years ago #

    I ran into an error and tracked it down. It looks like using [wp-legacy-stripe] to get the form inline on the page (rather than in the iframe) does not work in 1.4.0.

    After hitting the submit button I would get a long pause and then an error message on the page: "There was an error processing your card" And in the browser's error console:

    Error: ReferenceError: ajaxurl is not defined
    Source File: [domain omitted...]/wp-content/plugins/wp-stripe/js/wp-stripe.js?ver=3.4
    Line: 38

    I looked into this and it seems that the newer ajax code does not yet work with putting the form directly on the page via [wp-legacy-stripe].

    This is too bad because I like having the form on the page, and the iframe/pop-up is actually appearing *behind* my header in the default Twenty Eleven theme. (In that theme the header#branding CSS is set to z-index: 9999;)



  2. PaulMorris
    Posted 4 years ago #

    I forgot to say that when I tried it with the iframe/pop-up it worked fine that way. So that's how I knew it was a problem with [wp-legacy-stripe]. -Paul

  3. Noel Tock
    Human Made
    Plugin Author

    Posted 4 years ago #

    Hey Paul, have a live example somewhere? Can't reproduce, cheers.

  4. PaulMorris
    Posted 4 years ago #

    Hey Noel, Just sent you an email with my live example (instead of posting it here on the web). Hope you don't mind. Feel free to reply here. Thanks! -Paul

  5. hmoore71
    Posted 4 years ago #

    I just made a couple of relevant post in the "Uses other than donations"

  6. Noel Tock
    Human Made
    Plugin Author

    Posted 4 years ago #

    This is fixed now in 1.4.2

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Stripe
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.