Support » Plugin: WP Stripe » [Plugin: WP Stripe] httpss://

  • Resolved xhenxhe

    (@xhenxhe)


    When the setting for “Enable SSL for modal popup” is on, if the page being viewed is already https, the modal iframe doesn’t appear because it tries to access it via httpss (extra s). I think this bug should be easily resolved.

    Thanks!

    http://wordpress.org/extend/plugins/wp-stripe/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Noel Tock

    (@noel_tock)

    Human Made

    Extra s, hmm weird 🙂 Will look, thanks for letting me know!

    Plugin Author Noel Tock

    (@noel_tock)

    Human Made

    Alrighty, I’m guessing you already have another plugin for this, my code is as follows:

    if ( $options['stripe_modal_ssl'] == 'Yes' ) {
            $path = str_replace("http", "https", $path, $count);
        }

    What that’s telling me is that the link already is https:// , so just disable the option.

    xhenxhe

    (@xhenxhe)

    Yeah, I fixed it by disabling the option, just thought it would be best to check first to avoid confusing. What if on some blogs the https is not required and a user could may or may not be using https?

    Perhaps you could change the code to:

    if ( $options['stripe_modal_ssl'] == 'Yes' && substr($path, 0, 5) != 'https' ) {
            $path = str_replace("http", "https", $path, $count);
        }
    Plugin Author Noel Tock

    (@noel_tock)

    Human Made

    Sure, but that’s sending the wrong impression too (i.e. that the user thinks he has and needs SSL enabled on the wp-stripe when they don’t, because another plugin already handles what not).

    xhenxhe

    (@xhenxhe)

    Doesn’t sent the wrong message. Works as designed (add https if options is selected) but fixes the bug so it doesn’t change the the url to httpss – making it unusable.

    Plugin Author Noel Tock

    (@noel_tock)

    Human Made

    We can agree to disagree, I feel I just need to add it to the description 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP Stripe] httpss://’ is closed to new replies.