Support » Plugin: WP Socializer » [Plugin: WP Socializer] Twitter Button Permalinks?

  • Resolved Golfing


    This is a terrific plugin you have released – the best and most flexible of the social plugins I’ve tested.

    I noticed one issue, which I’m wondering if you can change/fix, or perhaps there is a setting I missed. Also one suggestion.

    1. Twitter Button function: The Twitter button (not the retweet button) that is selectable in the Social Buttons menu uses the WordPress post ID#, instead of the permalinks. Can you change it to use the permalinks? I noticed the other buttons, like FB use permalinks. For users, it can be confusing, in terms of whether they are linking to the correct page (Twitter shortens now anyway).

    2. Suggestion: This is a matter of taste, but you may want to implement it. I suggest a “no count” option for the Google +1 drop down (in the placement menu).

    Thanks for the terrific plugin…

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author vaakash


    Hello, Thanks for using my plugin. I am happy that it helped you so much.

    1. I enabled the “short url” for twitter giving space for article “title”. If you want shortening, then enter the bitly details in the “Settings” page.

    If you want the full post url, then do the following.
    – Open wp-socializer/wp-socializer.php
    – In the line 786, replace {s-url} with {url} Thats all.

    2. Nice idea Ill add it in the forth coming version.


    I’ve added the details but it isn’t using the links. Is this because I am adding the buttons using shortcodes?


    Plugin Author vaakash


    @rlparker81: Bitly will be used by Twitter buttons of the “16px and the 32px” social bookmarking buttons. The retweet buttons don’t use bitly for shortening URLs.

    ok. Is there anyway to get the retweet buttons to use the perma-link instead of /blog/?p=11156 ?

    Plugin Author vaakash


    Please follow the procedure as instructed in the post-2975279

    Hi, if you mean

    If you want the full post url, then do the following.
    – Open wp-socializer/wp-socializer.php
    – In the line 786, replace {s-url} with {url} Thats all.

    I tried that but it hasn’t made any difference

    Plugin Author vaakash


    Did you checkout the latest version v2.4.5 ??

    @ rlparker81,

    With version 2.4.5 open wp-socializer/wp-socializer.php and in the line 1571 you need to replace {s-url} with {url} so it looks like this:

    'url' => '{de-title}%20-%20{url}%20{twitter-username}',

    Then it will show the permalink instead of the page-id..



    Vaakash, thank you for the great plugin. I am hoping you consider using this url convention as the default in the future.

    When using the social buttons paramaters, setting url in a shortcode or in php doesn’t work with twitter, it only returns the current post’s link in shortcode. In other words, it can’t be overridden with parameters.

    Changing s-url to url, it now works perfectly to use something like

    [wpsr_socialbts services="facebook,twitter,email" url="" title="my title" excerpt="my excerpt" type="32px"]

    It would be great to not have to change the core plugin code to do this so it will be update friendly. Appreciate the consideration, thanks!

    Plugin Author vaakash


    Hello everyone,

    The newest version v2.4.6 has this bug fixed. Please update to that version and reply back if the issue persists. Thank you.



    Is it possible to add an option to select which URL should be used. I see three valuable choices:

    FULL, that is, full url as in permalink: {url}
    SHORT, that is, the url based on post ID: {s-url}
    TINY, that is, an url based on TinyURL (or similar service): {t-url}

    TINY is great for Twitter whereas FULL is better for FaceBook.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WP Socializer] Twitter Button Permalinks?’ is closed to new replies.