[Plugin: WP Social Blogroll] Not showinging last post (11 posts)

  1. spirit_97_97
    Posted 6 years ago #

    I added Social Blogroll today and it lists the feeds on my sidebar but it does not list the last post title. It leaves space between the links but there are no words.

    My site is at http://www.spiritblog.net.

    I'm getting this message -

    Content directory and/or JavaScript-file not writable!




  2. Erunafailaro
    Posted 6 years ago #

    The plugin will create a JavaScript file in your WordPress content-directory (in your case, this is /home/spiritbl/public_html/wp-content/). Therefore, this directory must be writable (chmod 777) at the moment, the Javascript-file is created for the first time.

    After that, the content-directory does not need to be writable as far as this plugin is concerned. I would recommend the following procedure:

    • Set /home/spiritbl/public_html/wp-content/ to chmod 777, e.g. by using your ftp-client.
    • Go to the plugin's option-page. Click on the JavaScript-tab and push the button to generate the Javascript.
    • Go back to your ftp-client and go to /home/spiritbl/public_html/wp-content/. You should find a file called feedreading_blogroll.js in it. Perfect!
    • The plugin will now be able to overwrite this file, even if /home/spiritbl/public_html/wp-content/ is no longer writable, so ...
    • ... set the directory /wp-content/ back to chmod 755, while letting the rights of feedreading_blogroll.js remain chmod 777.
  3. honeysss
    Posted 6 years ago #


    I also have same issue. I got message :

    JavaScript-file and content-directory are writable. This is no longer necessary. You should make the content-directory read-only (chmod 755) now for security-reasons.

    This plugin requires only JavaScript-file itself to be writable.


    I already change to chmod 755 but nothing happen.

    I also have checked :
    Enable JavaScript-sorting
    Show update-information
    Show title of latest post
    Show icon
    Enable bookmark preview

    Is there anything else i should do?

  4. honeysss
    Posted 6 years ago #

    I already able to view. I'm not aware there are new widget in widget page.
    I have already refer to below site. Thanks.

  5. Erunafailaro
    Posted 6 years ago #

    That message is a warning and not an error. You may ignore it if you are sure that your content-diretory has the correct setting and if it is not writable to everyone.

  6. SGallay
    Posted 6 years ago #

    On my blog, at http://alias.codiferes.net/wordpress, The Social Blogroll only shows the title blog and not the latest post.

    This happened when I updated the theme. Reinstalling the plug-in and rebuilding the JS file has no effect.

    Any clue what would need to be changed?

    Many thanks in advance

  7. SGallay
    Posted 6 years ago #

    Apologies for the bump, but does anyone has a clue?

    I know it's not exactly a show-stopper, but I quite liked it when it worked.

  8. Erunafailaro
    Posted 6 years ago #

    Hi SGallay,

    I see that you use WP-Minify on your blog. This is generally a good thing. But could you please try to turn that plugin of temporarily to test if the blogroll works correct without minify?

    I am using http://wordpress.org/extend/plugins/autoptimize/ instead of WP-Minify on my blog.

    Perhabs you could try that one as an alternative.

  9. SGallay
    Posted 6 years ago #

    Thanks for your reply!

    I have deactivated WP-Minify and rebuilt the Javascript, to no avail. I even deactivated the Grouped Links Widget, that actually was of no use anymore.

    Since this problem appeared when I switched themes, do you think it could be linked to a Javascript conflict with an element of the Lightword theme?

  10. Erunafailaro
    Posted 6 years ago #

    Yes, I think that is the problem. When I look at the theme-code with a jevescript-debugger (Firebug) I see that there is a problem with the script menu.js.

    This line causes an error:

    // activate cufon
    19Cufon.replace(['h1','h2'], { fontFamily: 'Vera' });

    Could you try to comment it like this:

    // activate cufon
    //19Cufon.replace(['h1','h2'], { fontFamily: 'Vera' });

    and then retry?

  11. SGallay
    Posted 6 years ago #

    Thanks a lot, this fixed it. I will mention this to the Lightword theme author.

Topic Closed

This topic has been closed to new replies.

About this Topic