WordPress.org

Forums

WP Smush - Image Optimization
[Plugin: WP Smush.it] Strange Error (49 posts)

  1. B_Dark
    Member
    Posted 4 years ago #

    1.i delete the rule yourdomain.com/wp-content*?
    2.how i clean my cloudflare cache?

  2. whitehallsd
    Member
    Posted 4 years ago #

    I just have the wp-admin page rule in. If you go to cloudflare settings, scroll down toward the bottom and you can clear the page cache.

  3. B_Dark
    Member
    Posted 4 years ago #

    still have the same problem :/

  4. damoncloudflare
    Member
    Posted 4 years ago #

    Hi Bdark,

    Are you asking how to edit/delete the rule? If you go back to the Page Rules page, you will see a gear icon that will let you edit or delete a rule.

    You can purge your CloudFlare cache by going to:
    settings->CloudFlare settings->Purge Cache

  5. damoncloudflare
    Member
    Posted 4 years ago #

    Hi,

    Just posting a solution that a customer sent me that appears to work when you modify a variable within the Smush.it plugin(s).

    if ( !$file_url ) {
      // determine the public URL
    $file_url = str_replace( 'SERVER PATH TO UPLOADS DOC', 'HTTP URL FOR
    DOCUMENTS IN UPLOADS', $file );
    }

    [Please post code or markup snippets between backticks or use the code button.]

  6. lindaloustarr
    Member
    Posted 4 years ago #

    @damoncloudflare - is this fix with or without setting page rule for wp-admin
    Linda Lou

  7. whitehallsd
    Member
    Posted 4 years ago #

    I just tried replacing with the code above but am oddly getting 500 errors on my site. I must not have the path correct or something. Oh well, mine is currently working without the modification in code so I will leave it alone.

  8. damoncloudflare
    Member
    Posted 4 years ago #

    Hi Linda,

    "is this fix with or without setting page rule for wp-admin"
    It is actually a modification to the actual plugin - so doesn't matter about the CloudFlare rules. I would still recommend keeping the wp-admin rule in place.

    note: We didnt' write the mod to the plugin, a community member did, so I don't want to say if it will work in all circumstances.

    Additional note:
    CloudFlare is testing a beta feature for image optimization for Pro accounts. If you are a Pro account already, you can test it out...just keep in mind that it might break something & you should turn it off in your CloudFlare settings (settings->CloudFlare settings) if you see a problem.

  9. B_Dark
    Member
    Posted 4 years ago #

    @damoncloudflare
    Am asking if I have to keep the rule yourdomain.com/wp-content* or delete it.
    Also,where should I add exactly the variable code?

  10. damoncloudflare
    Member
    Posted 4 years ago #

    @ B_Dark,

    I would delete the comment rule (keep the wp-admin* rule).

    I can't give directions for modifying the plugin (not my area of expertise...just shared because someone shared it with me). Probably not needed if the wp-admin rule fixes the issue.

  11. B_Dark
    Member
    Posted 4 years ago #

    Alright, but the right rule is wp-admin* or wp-admin/* ?

    But, I haven't seen any so far with wp-admin/*

  12. B_Dark
    Member
    Posted 4 years ago #

    any new?

  13. damoncloudflare
    Member
    Posted 4 years ago #

    Hi B_Dark,

    yourdomain.com/wp-admin/*

  14. B_Dark
    Member
    Posted 4 years ago #

  15. Dan Flippo
    Member
    Posted 4 years ago #

    All, I was able to use Smush.It without issue once I added a custom rule in Cloudflare Threat Control to trust the following Yahoo IP:
    98.136.171.205
    98.139.160.207

    Maybe you only need one of these. I added both and then tested that it worked.

  16. damoncloudflare
    Member
    Posted 4 years ago #

    Hi,

    Thanks for posting those IPs. I'm going to make sure that they are added to our Macro list.

  17. noisegate95
    Member
    Posted 4 years ago #

    Adding those ip's seems to have did the trick. Even when I was having to disable cloudflare, and wait 10 minutes, the results were iffy. As soon as I made these changes, no errors in smushing files (single or bulk).

    This is a relief, because having to manually send them up each time, was getting a little time consuming. :)

    Note edit: I think smushit.com is having service issues tonight (4/26/12), as I have completely errored out on a couple tries, and both times, I attempted to open their website, and it timed out.

  18. Richard Arellano
    Member
    Posted 4 years ago #

    I upgraded to 3.3.2 of wordpress a few days ago, and SmushIt was working fine as I've made a number of post (which I upload images) since. However today it seems to stop working.

    I keep getting HTTP errors when trying to upload and uploads hang to the point they time out. It was uploading the file but not making the thumbnails at all.

    I wasn't aware that SmushIt uses another off site service to smash images, that kind of breaks it for me. Seeing as I like to have control over such things, I figure it was a process being done on my server not a request to another server where it's process. Being it the site goes does well so does mine.

    If that's the case I wont be using it anymore and will have another way to make my images smaller. But after I disabled the plugin, I can now upload images no problem. I'm using Worpdress as multi-site by the way and not using any off site service to serve pages.

  19. damoncloudflare
    Member
    Posted 4 years ago #

    I'm just adding some quick troubleshooting tips that will make it easier to know if CloudFlare is causing an issue with a plugin or other. If you temporarily turn us off & the behavior goes away, then it is quite likely we are doing something.

    Troubelshooting CloudFlare Problems

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Smush - Image Optimization
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic