WordPress.org

Support

Support » Plugins and Hacks » WP Smush Image Optimizer » [Plugin: WP Smush.it] Strange Error

[Plugin: WP Smush.it] Strange Error

Viewing 15 replies - 16 through 30 (of 48 total)
  • Linda you should try change cloudflare dns settings.

    A yourdomainname.com points to ip…. with automatic TTL is on
    CNAME www. is on

    other dns settings try off

    Hmmm…still find it out that some say it happens without and with CloudFlare. Let’s try this…

    We have a beta feature called Page Rules that you can access here: https://www.cloudflare.com/preview-page-rules. After activating the beta, go to the Page Rules that you will in the CloudFlare settings drop down choices.

    You should then drop in your URL for the upload, such as:

    gigafytes.com/wp-content* (be sure to include the wildcard)

    The turn off all of the security and performance options (change cache to bypass cache, etc.).

    Note: I would also recommend excluding your admin url us, such as gigafytes.com/wp-admin*

    I tried your example above and then turned on cloudflare. Now getting the error again.

    Smush.it error: Could not get the image while processing http://whitehallsd.k12.wi.us/wp-content/uploads/2012/02/Classroom-Photos-2005-019.jpg (/home4/whitehb8/public_html/whitehallsdk12wi/wp-content/uploads/2012/02/Classroom-Photos-2005-019.jpg)

    Ok, I changed the pattern from wp-content* to wp-content/* It now seems to be working and I am going through cloudflare.

    My only concern now is that the wp-content folder contains many files that should be cached, and now they will not be with this exception correct?

    I tried the page rules this morning wp-content/uploads – smush.it is now working – however, by setting all the page rule settings to off & no caching won’t that make my site load slower since all my images are now not being cached?
    Linda Lou

    I don’t *think* that will be an issue because it is only stopping the upload portion from the admin section of your site from being touched. Try turning on the caching option for the page rule to see if that still allows the smush.it plugin to work. It could be another feature, not caching, impacting whatever it was (go to edit rule & change it from bypass cache).

    I just turned the page rule off – it was intermittenly causing some images not to load (absolutely cannot have that since my site is image intense & rich) – next time I smush I’ll try it with caching to see if it changes behaviour. Until there is a permanent fix maybe to just do a page rule to smush then deactivate it . . .
    Linda Lou

    So Damon:

    Are you saying that you think it is the wp-admin/* page rule that is helping this? If so, I will try it with the wp-content/* page rule off to see if that is the case. I am fine with bypassing the the wp-admin folder.

    Will post whether or not it works if I take the content page rule out.

    Hi,

    “Are you saying that you think it is the wp-admin/* page rule that is helping this?”

    We would generally recommend this (still beta testing). We’ve seen a number of issues with wp-admin, so better safe than sorry.

    Hi Linda,

    The page rule actually shouldn’t impact the image loading. If you have something specific to share, please do (much easier to look at).

    @damoncloudflare:
    1. I Have issues for both WP Smush.it & WP Smush.it NextGEN Gallery Integration
    2. W3 Total Cache
    3. WordPress 3.3.1
    i added the rules
    mysite.com/wp-content*& mysite.com/wp-admin* with security and perfomance off, Apps on and Custom caching: bybass cache…still have the same problem..:/ any idea for solution?!?!

    My issues started at 28 jan, some hours after that i activated my site on cloudflare, so definitely the problem coming from cloudflare

    Thanks Damon. The only rule that I have not is the wp-admin/* and it is working fine now.

    @whitehallsd
    Can you help me? What did you do exactly and made ​​it?

    If you use cloudflare, follow the directions above from Damon for putting in a page rule to have your wp-admin bypass the cache.

    example: yourdomain.com/wp-admin/*

    I also made sure I cleared all of my caches including w3tc and my cloudflare cache.

    That seemed to do the trick for me.

    1.i delete the rule yourdomain.com/wp-content*?
    2.how i clean my cloudflare cache?

Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘[Plugin: WP Smush.it] Strange Error’ is closed to new replies.
Skip to toolbar