WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Smush.it] Smush.it error: Failed to create a temp dir

[Plugin: WP Smush.it] Smush.it error: Failed to create a temp dir

  • Since the change to use Yahoo’s hosted version of Smush.it I keep getting this error when I try to manually smush a picture:
    Smush.it error: Failed to create a temp dir

    Also, when uploading a picture via the Media Uploader I’m just getting the return path of the image and have to explicity click ‘Save Changes’ to see the image, instead of being directly redirected to the uploaded image like it normally works.

    I’m on PHP 5.2, WordPress 2.8.2 and allow_url_fopen is enabled. Am I missing something? Any advice?

    PS Congratulations with your son’s birth! 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hey there,

    Got the same prob here.

    PHP 5.2 WP 2.8.2

    I just upgraded to .3 to see if it fixed it, but im getting a header error

    /home/www-911/htdocs/wp-content/themes/thesis_151/custom/images/ask-Ques.png
    
    Warning:  Cannot modify header information - headers already sent by (output started at /home/www-911/htdocs/wp-content/plugins/wp-smushit/wp-smushit.php:270) in /home/www-911/htdocs/wp-includes/pluggable.php on line 865

    Hello there,

    same issue here!

    Ditto, I’d say.

    It worked fine yesterday, but currently I am only getting the Smush.it error: Failed to create a temp dir error message.

    Must be a new API change by Yahoo… *grumble*

    Hi gang,

    From what I can tell, this is definitely a Yahoo! issue. Using their web interface ( http://developer.yahoo.com/yslow/smushit/ ) I’m seeing the same Failed to create a temp dir message in the debug panel.

    Smush.it has been pretty inconsistent over the past little while — I can’t get a response from Yahoo as to their intentions.

    For now, stay patient. I’ll post here as soon as I know any more.

    @djr — thanks!

    mrsolutions
    Member

    @mrsolutions

    I asked my host about the problem, they looked into it and concluded:

    Your image is being passed for processing to a php script at smushit.com. It is that script that is returning “could not create temp dir” and failing. Therefore, there isn’t anything you can do site/server wise to fix this issue. You will have to contact smush.it to get them to fix their script so that it can smush your images.

    @mrsolutions — yes, that’s exactly the problem. Out of our hands until Yahoo! does a fix.

    I’m impressed your host was willing to debug a third-party script. That’s rare.

    rhythmdoctor
    Member

    @rhythmdoctor

    Alex,

    In addition to this error, which Ill wait for, I had a change since updating whereby when I click on Smushit, it takes me to a blank page with the url for the image, but does not do a refresh to the media library as it used to. When I manually reload the page, it then goes back. Any ideas what would cause this?

    mrsolutions
    Member

    @mrsolutions

    Seems to be working again now

    corrynews12
    Member

    @corrynews12

    I’m getting “Error posting to Smush.it.” It’s showing for all my photos. It’s been this way since I added the plugin more than a month ago. any suggestions?

    Alex Dunae
    Member

    @alexdunae

    @corrynews12 — can you try clicking the ‘Re-smush’ link? I know Smush.it was down, again, for a brief period today.

    Im getting this problem with 1.2.6 – sometimes!
    I mean i will smush one image – fine, then smush the next – error posting… click smush again – then its fine.
    some images will not smush tho.
    ?

    It also happens, sometimes, when i upload an image.

    At least its half working!

    Would be good to add a batch smusher!

    So we can choose all images say in a directory, then smush all.

    thx

    centepines
    Member

    @centepines

    @welshhuw, same here. This seems to be a great tool, but it’s not realiable at all.

    @centepines: add this code to the .php file:-

    /**
     * Constants
     */
    
    define('SMUSHIT_REQ_URL', 'http://ws1.adq.ac4.yahoo.com/ysmush.it/ws.php?img=%s');
    
    define('SMUSHIT_BASE_URL', '');

    (Thanks to ocean90 for this)

    It should work fine.
    Im having no trouble today so far…

    Also, Would be nice if it had a ‘batch smusher’ that told you how much space you’ve saved!

    Yes I agree – its a great tool too!

    centepines
    Member

    @centepines

    @welshhuw I did it but I get this message instead of the old “error posting to”: ‘Error downloading file (Found)’

    I think I’m giving up 🙁

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: WP Smush.it] Smush.it error: Failed to create a temp dir’ is closed to new replies.