Support » Plugins and Hacks » [Plugin: WP Smush.it] SmushIt error – can't find file

  • OC2PS

    (@sooskriszta)


    Installed, tried on an existing image in media library, get an error

    Could not find /home/content/99/666777888/html/domainname/uploads/2011/04/image.jpg

    This in spite of the fact that the image is accessible.

    The address at which SmushIt is searching seems wrong. It should be looking for /home/content/99/666777888/html/domainname/wp-content/uploads/2011/04/image.jpg

    I should mention here that /home/content/99/666777888/html/domainname/ is absolute path for http://domainname.com

    http://images.domainname.com is mapped to /home/content/99/666777888/html/domainname/wp-content/uploads/ and WP retrieves images from http://images.domainname.com/

Viewing 12 replies - 1 through 12 (of 12 total)
  • OC2PS

    (@sooskriszta)

    Anyone?

    That’s super strange. I had to push out the 1.4.2 release today to reduce the load on Yahoo’s servers. I’ll investigate this issue and try to get a fix out promptly.

    OC2PS

    (@sooskriszta)

    Thanks!

    Bated breath, etc

    Can you give this a go and see if it’s any better?

    http://dialect.ca/code/wp-smushit/wp-smushit-1.4.3beta.zip

    Cheers,
    Alex

    Got the same error .

    Can you give this a go and see if it’s any better?

    http://dialect.ca/code/wp-smushit/wp-smushit-1.4.3beta.zip

    Will check out this version

    OC2PS

    (@sooskriszta)

    Sorry, Alex, WP didn’t send me an email upon thread update so didn’t realize you posted a Beta here.

    I see that you have released 1.4.3 now, so instead of the Beta, I will try the released version now and get back to you.

    OC2PS

    (@sooskriszta)

    Didn’t work at first, but then I realized that when I mapped http://images.domainname.com to /home/content/99/666777888/html/domainname/wp-content/uploads/ then I had to change folder to uploads from /wp-content/uploads/ and I guess that’s what WP SmushIt! is reading to access the files.

    The problem can be resolved if instead of using folder, WP SmushIt! uses the path!

    Will check out this version

    Same problem with 1.4.3 version too

    I’m trying to track down where this is happening, but can’t seem to replicate the errors you’re getting.

    In my WP wp-admin/options-media.php settings, I’ve set the full url path to http://images.example.com and left the folder completely blank.

    In my Apache vhost config I’ve got

    <VirtualHost *:80>
        DocumentRoot "/path/to/example.com/wp-content/uploads"
        ServerName images.example.com
    </VirtualHost>

    The resulting uploads generate URLs like: http://images.example.com/2011/11/image.jpg

    How do our settings differ?

    OC2PS

    (@sooskriszta)

    With those settings, try smushing already uploaded images. That’s where we seem to have trouble.

    Just tried it — still worked. Very strange.

    Just to confirm, your Store uploads in this folder setting is blank, right? Does it work if you set it to wp-content/uploads or /home/content/99/666777888/html/domainname/wp-content/uploads/ ?

    What WP version are you using?

    The problem can be resolved if instead of using folder, WP SmushIt! uses the path!

    Can you tell me more about this — which folder vs. path, and where?

    I’d love to get this working; I just can’t seem to replicate it.

    OC2PS

    (@sooskriszta)

    Sorry, seems WP forums don’t allow adding screenshots.

    If you go to WP Admin > Settings > Media > Uploading Files,
    you’ll see 2 fields:
    Store uploads in this folder
    Full URL path to files

    I think the issue might be resolved, if you use Full URL path to files, if it exists

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WP Smush.it] SmushIt error – can't find file’ is closed to new replies.