WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Smush.it] Not Smushing it!

[Plugin: WP Smush.it] Not Smushing it!

  • Problem when trying to smush images in the media libary. This message appears… E:Domainsn.microlise.comwwwrootwp-contentuploads20101Crewchief-screen-shot-2.gif must be within the content directory (E:Domainsn.microlise.comwwwroot/wp-content).

    Can anyone help me!, Any help would be much appreciated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • There’s currently a bug in the plugin on Windows servers. I’ll be addressing that shortly.

    Version 1.2.8 should resolve this, available any minute now. Let me know if you run into any other issues.

    Cheers,

    Alex

    I’m running V 1.2.8 and having the same “must be within the content directory” on a linux shared machine. I have moved the uploads directory from wp-content/uploads to media. Does WP-SmushIT recognizing content directories that have moved using the Misc tab under Settings?

    This plugin is very useful, thank you!

    I’m having the same problem though, I want the uploads folder to move to a subdomain of my site. I can do this no problem within wordpress, but when I try to smush images, I get the same error: must be within the content directory. Is there any way I can make this happen?

    I’m using Version: 1.2.8

    The directory checking will disappear in the next version. Hang tight…

    I’ve got a beta version that could have this fixed, available at http://code.dunae.ca/tmp/wp-smushit.zip

    Give it a try and let me know how things work for you.

    Will this get in plugin? Why there is this limitation anyway?

    Getting the same error even with the latest version. I think this plugin is hard-coded to assume the /uploads/ dir is within /wp-content (which is wrong, goddamnit).

    Anyway, are there any hopes to fix this for blogs that have a different uploads dir configured?

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: WP Smush.it] Not Smushing it!’ is closed to new replies.
Skip to toolbar