WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Smush.it] Http error with WordPress 3.1

[Plugin: WP Smush.it] Http error with WordPress 3.1

  • When uploading a picture within a post, I get, “http error.” I disabled all other plugins and narrowed it down to the smushit plugin.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’m having the same problem! I’ve disabled the smushit plugin for now until I can figure out a solution. Hopefully someone can resolve this soon because this plugin is awesome!

    Same problem here too.
    That or as soon as I try to upload a picture, it tries to crunch it indefinitely.

    I have been doing some digging into this problem.

    To make a long story short, I got it sort of working in 3.1 by commenting out “add_filter(‘wp_generate_attachment_metadata’, ‘wp_smushit_resize_from_meta_data’);” at about line 41. It won’t smush.it automatic upon upload, but will allow to manual Smush.it.

    From what I can tell by tracing the code, is that every time attachment metadata is accessed, it fires the filter/function on about line 41. So when you open up the media library and it accesses the metadata for each attachment in the library, it tries to smush.it each images. On my server it usually results in a timeout or HTTP 500 error.

    Also, something may have changed that effects “wp_update_attachment_metadata($attachment_ID,$new_meta);” on about line 96. I can see the images being sent to smush.it and the new metadata array but the attachment metadata isn’t being updated in the database. I even tried “update_post_meta($attachment_ID, ‘_wp_attachment_metadata’, $new_meta, $original_meta);”

    This is about as far as I got. Hope this helps.

    Thanks for you help, but as I’m not a coder, I don’t really understand anything at what you typed. 🙁
    What I did is that I disabled smush it, hoping for an update soon.

    @gbrooks thanks for looking into it. I hope there is a solution that doesn’t involve editing the code, though.

    Plugin Contributor Alex Dunae

    @alexdunae

    Thanks for your patience everyone. I believe I’ve traced the issue but, before I release another version of the plugin I’d be grateful if any of you could try out the new version and report back if it works for you:

    http://dialect.ca/code/wp-smushit/wp-smushit-1.3.5.zip

    Cheers,
    Alex

    hi alex

    yes, that’s now working for me.

    i am seeing an error on the library media screen though – in the smush.it column, after items that are not images (e.g. PDFs), it says “could not find /var/www/……/wp-content/uploads”. it would be nicer if it said “not smushable” or something like that.

    cheers!
    simon

    I’m completely new to smush-it 😉

    As far as i have tested smushit-1.3.5 works fine on WP 3.1.2 although i sometimes get ‘Could not find /usr/www/users/pjat1/root/wp-content/uploads/’ when i call smushit manualy via the mediathek.

    -Alex

    Working in —> Version 3.1.2

    Thx Alex Dunae

    Still not working for me, images won’t crunch. Seems to only happen with one of my themes though, on the other one it works fine. The images will upload they just won’t crunch.

    Upgrading to WordPress 3.1.2 also did the trick for me, too!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WP Smush.it] Http error with WordPress 3.1’ is closed to new replies.