WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP Smush.it] – 900×488: Smush.it error: Could not get the image while processing

[Plugin: WP Smush.it] – 900×488: Smush.it error: Could not get the image while processing

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Jan Dembowski

    @jdembowski

    Clear your browser’s cache and click on that image link. You’ll see what’s going on.

    It’s your hotlink protection from CloudFare that’s preventing SmushIt from working.

    Hello, disabling hotlink protection didn’t do it.

    Moderator Jan Dembowski

    @jdembowski

    Now that that’s disabled, try Smush’ing a new image for testing.

    Also what happens when you smush the image manually via the URL tab?

    http://www.smushit.com/ysmush.it/

    When I smushed your image manually, it worked…

    Hello, I tried uploading a new image and it didn’t smush.

    Smush.it error: Could not get the image while processing http://www.maxvideogaming.com/wp-content/uploads/2012/03/IMG_1984.jpg (/home/derp/public_html/maxvideogaming.com/wp-content/uploads/2012/03/IMG_1984.jpg)

    Moderator Jan Dembowski

    @jdembowski

    That’s weird. It was definitely the hotlinking issue before.

    Check your web server’s error_log file, with hotlink protection turned off, Yahoo’s service should be able to fetch those images without a problem. The error log may have more information as to why it’s failing now.

    Where is that server error_log file? I went into cPanel and checked the error log and it was completely empty. I’ve turned hotlink protection from Cloudflare off and it was never enabled in cPanel anyway.

    Weird.

    Moderator Jan Dembowski

    @jdembowski

    Weird is right. Sorry, but I’m out of ideas. When you use the plugin, it uses Yahoo’s API to say “Hey, smush this for me and I’ll get/receive the smushed version.”

    With that protection on, it was simple: Yahoo couldn’t get that image. Now that they can, it’s unclear why it’s not working for you.

    Hey, thanks for all the help. I have contacted my host and they have created a ticket for me.

    AD7863, I seem to be having the same issue as you have reported here. Did your host provide a solution and perhaps details on why the problem occurred in the first place? Smush.it has always worked fine for me until today.

    Sorry, unfortunately my host hasn’t provided me with a solution yet. Apparently they don’t know what’s going on.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WP Smush.it] – 900×488: Smush.it error: Could not get the image while processing’ is closed to new replies.