WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP SlimStat] outbound not tracking

[Resolved] [Plugin: WP SlimStat] outbound not tracking

  • Hi,
    Slimstat is succesfully tracking visits and pages and so on, but doesn’t seem to be able to track outbound clicks.

    I can see all the statistics, but ‘Recent Outbound Links’ remains empty.
    Also, in the settings-Maintenance, the wp_slim_outbound remains empty:
    wp_slim_outbound: Size: 1.00 KB | Records: 0 | Average Record Length: 0 bytes | Created on: 2012-03-22 11:30:56

    Since my template is quite complicated (bought and adjusted), I wouldn’t like to disable other plugins to check if these are the cause and then find out that my site is screwed… these are:
    Contact Form 7, Google Maps v3 Shortcode, qTranslate, Really Simple CAPTCHA, WP-PageNavi, WP Smush.it

    Perhaps related: if I click on an external link using an image instead of text, it will open the window with only the image. If I use class=”noslimstat”, it will open the external page fine (but still not tracking). And if I add onclick=”ss_te(event,0,true)” to that same link, it will fail again.

    I have tried adding above parameters (class=”noslimstat”, onclick=”ss_te(event,0, true)”) and as I mentioned, it does change behaviour and standard tracking keeps working, but the outbound links are not being tracked.

    have you got any other suggestion than deactivating the other plugins?
    Cheers.

    http://wordpress.org/extend/plugins/wp-slimstat/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jason Crouse

    @coolmann

    Hi there,

    I’m sorry about the inconvenience you’re experiencing. It looks like the Javascript used to track outbound links is not being properly initialized. You can contact me at

    la buca delle lettere

    with the URL of your website, so that I can take a look at the issue and help you find a solution!

    Cheers,
    Camu

    PS: it could also be a bug in the Javascript. The bugfix will be available in version 2.8.1, but I may need to ask you to test the new version in advance to see if it works.

    Hi Camu,

    I responded to you on your contactpage, but it returns the HomerSimpson response, I reckon you didn’t receive my answer…

    The site is antillaconsulting_com (to check out the outbound tracking not working)

    In specifically, the link I would like to work is the one on the page Colaboradores, the link to PlanB (either text or image link).

    Thanks for following up so quickly!

    Cheers

    Plugin Author Jason Crouse

    @coolmann

    Hi there,

    Try removing the onclick handler on that link: since you don’t have class=”noslimstat”, the tracking is being done twice. Also, the new version should help in your case. How do I contact you?

    Camu

    Hi Camu,

    Thanks again for getting back to me.
    I have tried before without the onclick and/or the noslimstat, but no luck. But to be sure, will test it again now.

    I tried as well to contact you again via your site, but Homer keeps coming back, dunno why?

    You can contact me on: ftrippie “arroba” yahoo “punto” co “punto” uk

    cheers

    Plugin Author Jason Crouse

    @coolmann

    Just sent you a message with the new files.

    Let me know if it works!

    Camu

    After some testing and updating files , we sorted it (1 row missing in MySQL)and now it works perfectly!

    Thanks for all your efforts and dedication!

    cheers!

    Plugin Author Jason Crouse

    @coolmann

    Thank you for your patience!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: WP SlimStat] outbound not tracking’ is closed to new replies.