Support » Plugin: Slimstat Analytics » [Plugin: WP SlimStat] missing tables

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    How big is your network?

    6 blogs prepaired
    2 active (are part of this 6 blogs)
    http://www.PROnatur24.eu
    http://www.elektroroller24.com

    Plugin Author Jason Crouse

    (@coolmann)

    Any chance to take a look at the MySQL log file? Those three tables are “shared” by all the blogs in the network, so it could be because of a misconfiguration in your network (wp-config). How many tables were created in total? Also, what version of MySQL are you using?

    I’ll ask my provider. But I’ve checked my database. All tables are “MyISAM” only slimstat was added with “InnoDB”. Than all tables are using “utf8_general_ci”, slimstat is using “latin1_swedish_ci”. It seems there is no autodetection. Is this a problem?

    I’m using:
    Apache
    MySQL-Client-Version: 5.1.43
    PHP Extension: mysql

    please check:
    http://pronatur24.eu/files/screen.png

    Plugin Author Jason Crouse

    (@coolmann)

    Yes, SlimStat uses InnoDB if available, and a more generic encoding, in order to store information coming from search engines not using Western characters (Russian? Chinese? etc). That should not be a problem. Let’s see what your provider says.

    Camu

    Bad. My provider can’t help me. It’s a shared system.
    Is it possible to add the missing tables manualy?

    Plugin Author Jason Crouse

    (@coolmann)

    Yes, of course. Just copy the corresponding SQL code from wp-slimstat.php into phpmyadmin. Be careful to use the same “general” table prefix you configured in your wp-config.php.

    Camu

    Hi Camu. I’m really NOT a professional in working with databases. I try today but it’s to much complicated for me. Is there a possibility that I can send you my prefix for this two blogs by email and you send me the necessary sql-code as answer? I found a lot of coding for this 3 tables, to much for me. I’ll risk my database. Otherwise I have to deactivate this nice plugin, because today I received from a user following failures.

    Warning: fsockopen() [function.fsockopen]: unable to connect to updates.browserproject.com:80 (Connection timed out) in /wp-content/plugins/wp-slimstat/browscap.php on line 589

    Warning: file_put_contents(/wp-content/plugins/wp-slimstat/cache/cache.php) [function.file-put-contents]: failed to open stream: Permission denied in /wp-content/plugins/wp-slimstat/browscap.php on line 366

    I fix this by deactivating. I really can pay you for this work – no problem. I need: wp_slim_browsers, wp_slim_countries, wp_slim_screenres

    Plugin Author Jason Crouse

    (@coolmann)

    This Warning thing is unrelated to the database. Please change the permissions for /wp-content/plugins/wp-slimstat/cache/cache.php so that the webserver can update that file. Or deactivate the corresponding ‘autoupdate’ option in the settings. WP SlimStat is trying to download/update the browsers’ detection library, but it can’t because that file cannot be overwritten. This will probably be fixed in a future release, when I’ll start using WP built-in filesystem library.

    Camu

    No difference. I did what you said. And there was also today an update with this plugin. But nothing better, I still missing wp_slim_browsers,
    wp_slim_countries and wp_slim_screenres.

    Plugin Author Jason Crouse

    (@coolmann)

    Yes, but what about the file error? Is that still occurring? As for the other one, it must be some problem with your server configuration. Manually creating the tables is the only way to fix the issue.

    CREATE TABLE IF NOT EXISTS wp_slim_countries (
    				ip_from INT UNSIGNED DEFAULT 0,
    				ip_to INT UNSIGNED DEFAULT 0,
    				country_code CHAR(2) DEFAULT '',
    				CONSTRAINT ip_from_idx PRIMARY KEY (ip_from, ip_to)
    			)
    
    CREATE TABLE IF NOT EXISTS wp_slim_browsers (
    				browser_id SMALLINT UNSIGNED NOT NULL auto_increment,
    				browser VARCHAR(40) DEFAULT '',
    				version VARCHAR(15) DEFAULT '',
    				platform VARCHAR(15) DEFAULT '',
    				css_version VARCHAR(5) DEFAULT '',
    				type TINYINT UNSIGNED DEFAULT 0,
    				PRIMARY KEY (browser_id)
    			)
    
    "CREATE TABLE IF NOT EXISTS wp_slim_screenres (
    				screenres_id SMALLINT UNSIGNED NOT NULL auto_increment,
    				resolution VARCHAR(12) DEFAULT '',
    				colordepth VARCHAR(5) DEFAULT '',
    				antialias BOOL DEFAULT FALSE,
    				PRIMARY KEY (screenres_id)
    			)

    Make sure wp_ is your actual WordPress prefix (check your wp-config.php)

    Let me know if you have questions,
    Camu

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: WP SlimStat] missing tables’ is closed to new replies.