Support » Fixing WordPress » [Plugin: WP Security Scan] Warning simplepie.inc on line 759

  • Resolved baslaan

    (@baslaan)


    Donations:
    Highest

    Warning: ABSPATH.”wp-content/plugins/wp-security-scan//********************.spc is not writeable in /var/www/vhosts/************.com/httpdocs/wp-content/plugins/wp-security-scan/simplepie.inc on line 759

    Hi can anyone help me out with this warning?

    Thanking you in advance!

Viewing 11 replies - 1 through 11 (of 11 total)
  • I am seeing the same issue after upgrading to the latest WP Security Scan. It appears to only effect the list of donors but maybe it is effecting more?

    Warning: ABSPATH.”wp-content/plugins/wp-security-scan//345345345345345345345ebebe.spc is not writeable in /path/to/wordpress/wp-content/plugins/wp-security-scan/simplepie.inc on line 759

    LIST OF DONORS HERE

    English Language Services Limited http://englishlanguageservices.co.uk
    Recent

    Warning: ./cache/bc3d4fa0be92dcdcbab71158e44da674.spc is not writeable in /path/to/wordpress/wp-content/plugins/wp-security-scan/simplepie.inc on line 759

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Make sure you’re using 2.3.9, and let me know whether you still see an error.

    Hello!

    I was having the same error as you, but could deal with two simple steps:

    If you are seeing this error in both parties, follow both steps. If you are only seeing the error in the “Recent”, you should jump straight to step two. This works to version 2.3.9 of WP Security Scan.

    [1] – Check the folder permissions for the folder “wp-security-scan”, which is within “wp-content/plugins”. Change to 777 (use CHMOD).

    Explanation: The WP Security Scan use the folder “wp-security-scan” to unload the cache of feeds, so the folder must be writable.

    [2] – Open the file “securityscan.php” which is located in the “wp-content/plugins/wp-security-scan.” Inside, the line 154 you find:

    Line 154: $ feed-> init ();
    Line 155: $ feed-> set_cache_location (ABSPATH. "wp-content/plugins/wp-security-scan / ');

    Invert these lines. This will:

    Line 154: $ feed-> set_cache_location (ABSPATH. "wp-content/plugins/wp-security-scan / ');
    Line 155: $ feed-> init ();

    Explanation: The feed was being initialized before being set in the variable (the support staff should review these lines for the next update.)

    This will solve your problem, I think …

    All the best for you!

    P.S.: Don’t forget to give feedback telling if it worked!

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    TBaroni,

    #1 shouldn’t be needed
    #2 has been addressed in version 2.4, please let me know if this fixes the issue

    Hello hallsofmontezuma,

    Thanks for the quick fix.

    Whoops. I had posted this did not resolve the issue however the upgrade via the WP admin interface must have not been successful the first time. I upgraded again through the interface and this time I am now on WP Security Scan 2.4 and the issue is resovled.

    Thanks!

    Hi hallsofmontezuma!

    #1 To me the first action was needed… But my server is weird, so… By the way, someone can need to do that too…

    #2 I think is fixed on that new version…

    @hallsofmontezuma

    Recent update fixed both problems!

    Thank you for the quick fix 🙂

    Updated this topic to resolved.

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    You’re welcome baslaan. Let me know if anything else seems to be an issue. Keep an eye out for updates, as there will be additional functionality from time to time.

    didierjm

    (@didierjm)

    sorry, I created a post here with a pb, but as the issue is resolved, I’ll create a new thread instead.
    Sincerely
    DJM

    i’ve just fixed the same problem by following “TBaroni”‘s first instruction which is below, it really did worked for me.

    [1] – Check the folder permissions for the folder “wp-security-scan”, which is within “wp-content/plugins”. Change to 777 (use CHMOD).

    do try it before playing with .php files

    thanks guys!

    Peace~

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: WP Security Scan] Warning simplepie.inc on line 759’ is closed to new replies.