WordPress.org

Forums

WP RSS Multi Importer
[resolved] Google News Feed not working (14 posts)

  1. alyland
    Member
    Posted 2 years ago #

    Hello.
    I am trying to get a google news feed to work but I get the following error:
    Warning: file_get_contents(http:https%3A//news.google.com/news/feeds?pz=1&cf=all&ned=us&hl=en&output=rss?format=xml): failed to open stream: No such file or directory in (my server / database) on line 88 Warning: Invalid argument supplied for foreach() ...
    I can use other feeds with no problem, why is the google news feed in particular tripping me up?
    Thanks in advance!
    Aly

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

  2. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    can you point me to the page where you are are trying to get the RSS feed...this is the feed RSS I use which works fine

    http://news.google.com/news?pz=1&cf=all&ned=us&hl=en&output=rss

  3. alyland
    Member
    Posted 2 years ago #

    For trouble-shooting, I just entered in the url above and still no dice.

    Here's my page with error: http://www.principalrealestateservices.com/?page_id=14

    I tried zen habits to see if it was google or me and it worked fine...

  4. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    ok...can you send me the RSS feed urls you are trying to use in the plugin...that would really help me understand what might be going on. Thanks.

  5. alyland
    Member
    Posted 2 years ago #

    I entered yours from above (http://news.google.com/news?pz=1&cf=all&ned=us&hl=en&output=rss) to test... with the same error: That is the one that is currently in there.

    The one that worked was:
    feed://feeds.feedburner.com/zenhabits?format=xml

    Thank you for the quick replies, btw.

  6. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    ok...well, are you using the most updated version of the plugin? Assuming you are, then I'm not sure what is going on yet...here is what I get when using both of your feeds:

    http://screencast.com/t/VrsHrKVw

  7. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    also, it looks like you're trying to set this site up, so if you want to give me temporary log in access I can get this working for you...just send me email to me@allenweiss.com

  8. alyland
    Member
    Posted 2 years ago #

    I was getting the error last week and updated over the weekend... so the update isn't the issue. It's just so weird that one will work and the other will not.
    I appreciate you trying.

  9. alyland
    Member
    Posted 2 years ago #

    Okay - I'll make you a log in. Thanks!

  10. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    ok....it looks like there is a problem with the way Google news RSS works. You can get a sense of the problem here:

    You can get a sense of the problem here and more recently here...so this is happening even with WordPress's own widget.

    Right now, my plugin relies on WordPress's RSS reader, called SimplePie. It appears to have problems on certain servers (for example, I can't reproduce the problem on my web site, but others see this happening on their sites)..Anyway, it does not appear to be consistent. Since SimplePie is not being updated, there is no telling when this bug will be fixed (it's out of my control). I'll be looking for another RSS parser in a future version to get away from this problem.

  11. alyland
    Member
    Posted 2 years ago #

    Thanks for all of your help. I am using a Yahoo News Feed for now and hopefully someone out there will figure out the google issue soon. I am nowhere close to smart enough to figure it out on my own! You've been great, Allen.

  12. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    No problem....I hope someone figures it out too. Also, please spend a moment and rate my plugin by going to

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

    That would really help others decide whether to try out this free plugin or not.

    Best wishes,
    Allen

  13. leap500
    Member
    Posted 2 years ago #

    It looks like it fails when the url is https:// rather than http://

  14. Allen
    Member
    Plugin Author

    Posted 2 years ago #

    Right..what I've determined is that it depends on the hosting platform you're using and whether they allow you to pull a secure feed or not. For example, on my development server I have no problem with https feeds, but will on another server.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic