Support » Plugin: WP RSS Multi Importer » [Plugin: WP RSS Multi Importer] Errors after update

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Allen

    (@amweiss98)

    Thanks..ok, for me to help, I need to know
    a) what are the errors you are getting
    b) an example of an RSS feed you are using
    c) do you have a web site url that I could see the errors on?

    Thanks,
    Allen

    A. Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\wordpress\wp-content\plugins\wp-rss-multi-importer\wp-rss-multi-importer.php on line 1312

    Warning: array_multisort() [function.array-multisort]: Argument #1 is expected to be an array or a sort flag in C:\xampp\htdocs\wordpress\wp-content\plugins\wp-rss-multi-importer\wp-rss-multi-importer.php on line 1323

    B. http://feeds.feedburner.com/gybblog?format=xml

    C. I do not have a website (still testing)

    Plugin Author Allen

    (@amweiss98)

    ok….I’m not getting this on my development server (I use MAMP). I’ll need to look into this (the error suggests something is going on with the array – If you know php and could do a var_dump($myarray) on line 1309 that would help see what’s going on since unless I can reproduce the error it’s tricky, but I’ll see what I can do.

    Are you getting same error when using other feeds, like say

    http://feeds.gawker.com/Lifehacker/full

    Plugin Author Allen

    (@amweiss98)

    any luck with the gawker feed? If you want, I can send you a file that, if you replace the main file plugin, will give me the diagnostics to possibly seeing what’s going on.

    Sorry for the delay. I switch the themes and the error messages are gone. However, I am still having errors. For example, prior to the last update, I was able to get two feeds on my landing (latest posts) page and I had the two feeds on separate pages. Now only one feed is showing up on the landing (latest posts) page and one of the pages displays a feed. Also, I do not know much php code. Therefore I was not able to var_dump($myarray) on line 1309. Moreover, I added the Gawker feed and it displays. However, it will not show if there are more than one feed on the landing page.

    Plugin Author Allen

    (@amweiss98)

    Hi
    I’ll send you a solution for this in a couple of hours.

    Plugin Author Allen

    (@amweiss98)

    ok..here is a quick fix until I push an update tomorrow afternoon with this fix..if you know how to edit
    the plugin’s files in wordpress,

    if you don’t know, you can see where this is by watching this

    http://screencast.com/t/9XTZ8a

    go into the main plugin file
    (wp-rss-multi-importer.php) and change line 1387 (which is near the bottom of the file) from this:
    require_once ( WP_RSS_MULTI_TEMPLATES . $template );
    to this
    require( WP_RSS_MULTI_TEMPLATES . $template );

    Plugin Author Allen

    (@amweiss98)

    also, please spend a moment and rate my plugin by going to
    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

    It helps a lot with motivation since I don’t make any money improving this plugin 🙂

    The last solution solved the problem. Thanks! Also, I’ve rated your plugin, and I will be making a donation later on this week toward your plugin.

    Plugin Author Allen

    (@amweiss98)

    Thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: WP RSS Multi Importer] Errors after update’ is closed to new replies.