WordPress.org

Support

Support » Plugins and Hacks » [Plugin: WP RSS Images] Images not showing up in RSS readers though present in feed

[Plugin: WP RSS Images] Images not showing up in RSS readers though present in feed

  • I have WP RSS Images enabled to add medium photos to my RSS feed with the media tag. I am using the excerpt (rather than full) setting for RSS feeds.

    Feed: wednesdaysinmhd.com/feed/rss2

    The images showed up for a short period of time in Google Reader but now are absent. Tried the enclosure tag but that just showed an enclosure; not the image. Tried designating the rss2 feed specifically but didn’t make a difference.

    Curiously, the images show up fine in my MailChimp RSS to email campaigns so I know they are in the feed.

    Hoping someone can help me with this.
    E

    http://wordpress.org/extend/plugins/wp-rss-images/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, I see the same problem. Did you resolve it?

    Try this:

    Add Featured Image to RSS Feed
    in functions.php file
    Add at end:

    function featuredtoRSS($content) {
    global $post;
    if ( has_post_thumbnail( $post->ID ) ){
    $content = '<div>' . get_the_post_thumbnail( $post->ID, 'medium', array( 'style' => 'margin-bottom: 15px;' ) ) . '</div>' . $content;
    }
    return $content;
    }

    ilittauer

    @ilittauer

    My images are coming in as links when I view in Google Reader. An example is:

    Original enclosure (510a4YwWEaL._SL500_AA300_.jpg)

    Any idea how to get the image to just appear. My goal is to get thumbnails to show up in my weekly MailChimp RSS email.

    Any help would be greatly appreciated. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: WP RSS Images] Images not showing up in RSS readers though present in feed’ is closed to new replies.