WordPress.org

Support

Support » Plugins and Hacks » WP RSS Aggregator » [Resolved] [Plugin: WP RSS Aggregator] Errors W/2.0 Version After Upgrade

[Resolved] [Plugin: WP RSS Aggregator] Errors W/2.0 Version After Upgrade

  • As soon as I upgraded to 2.0 my display results crash and show the following:

    Warning: date() expects parameter 2 to be long, string given in /home/content/73/8810373/html/wp-content/plugins/wp-rss-aggregator/wp-rss-aggregator.php on line 377

    Any insight in how to fix this issue would be greatly appreciated, as I don’t know PHP code. My only solution at this point is to pull it back to 1.1 which does not give me this error.

    Thanks

    http://wordpress.org/extend/plugins/wp-rss-aggregator/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jean Galea

    @jeangalea

    Try replacing line 377 with the line below, and let me know how it goes, if it works fine I will release an update. I can’t reproduce the error on my setup but this should do the trick.

    $date = date( 'Y-m-d', intval( get_post_meta( get_the_ID(), 'wprss_item_date', true ) ) );

    That has fixed the error on my end, however I notice now that in the new version of the plug in, there are no headers anymore? It use to have groups like 2 Days Ago, or Last Week, etc.

    Now it’s just a straight list?

    Is there a new setting or code I missed?

    Plugin Author Jean Galea

    @jeangalea

    That’s right, there were quite a number of requests asking for their removal so I did so. There will soon be a number of extensions released though, and this feature can be in one of them.

    Many thanks for your feedback.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: WP RSS Aggregator] Errors W/2.0 Version After Upgrade’ is closed to new replies.
Skip to toolbar