Support » Plugin: WP-reCAPTCHA » [Plugin: WP-reCapatcha] incompatible with v3.1.1

  • tried to install this plugin manaually to test it’s compatibility with 3.1.1 (literally just updated to 3.1.1, kind of annoying) And i get this error;


    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot redeclare recaptcha_wp_blog_domain() (previously declared in [worpress directory]/wp-content/plugins/tantan-spam/plugin.php:467) in [worpress directory]/wp-content/plugins/wp-recaptcha/wp-recaptcha.php on line 600

    Hopefully this will be fixed soon, as this plugin looks really helpful

    Cheers,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You do know that there is an alternative to reCapatcha. It’s called SI CAPTCHA Anti-Spam and it is compatible with WP v3.1.1. Here is the link to the plugin: http://wordpress.org/extend/plugins/si-captcha-for-wordpress/ NOTE: This will not work with the reCapatcha keys as this is not reCapatcha. This plug-in is also compatible with Akismet.

    Worked GREAT in WP 3.1.1!! Until I upgraded it this morning. Now all I get is:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in [wordpress directory]/wp-content/plugins/wp-recaptcha/recaptcha.php on line 8

    Was gonna try to uninstall and reinstall and got:

    Parse error: syntax error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in [wordpress directory]/wp-content/plugins/wp-recaptcha/plugin.php on line 10

    TerrificTony, I had exactly the same problem. I ended up recreating my php.ini file and the problem was fixed. My hosting provider had updated the version of php on the server, but I was still running the old php.ini file.

    happened to our site too.

    what does “recreating the PHP.INI” file mean? I know what that file is (sort of) but don’t know how to do it… probably the hosting company’s responsibility right?

    Any other official fixes, or wait for an upgrade from Jorge?

    Most likely it is the hosting companies responsibility. If you aren’t sure of what you are doing, don’t mess with the php.ini file. File a support ticket with your provider.

    Having said that, I was able to fix it myself from cPanel (I’m using Bluehost.com for my hosting). Your hosting provider may or may not provide cPanel, and it may or may not have the ability to recreate the php.ini file. This is, in general, what should be done:

    You will need to install a new php.ini file. Then, any changes you had previously made to the php.ini file, you will need to modify again. You can create a php.ini file in the cPanel using the PHP Config tool. Make sure you are using PHP5 (Single php.ini). Save the Changes. Mark the checkbox for Ioncube. Click on “INSTALL PHP.INI MASTER FILE”. This creates a file in public_html named php.ini.default. You will need to rename that file to php.ini . This file can be renamed using the File Manager inside cPanel.

    Once again, this worked for me on bluehost.com. It may not work for others. It may break your entire site. Be sure and make a backup of your php.ini file so that you can replace the new php.ini if it does not work. While I am a strong fan of experimenting to figure out how things work, be sure and retain the capability to get back to a working configuration before you start.

    Yeah, after I installed SI Captcha (thanks to dog0012’s recommendation) I saw a warning error in that plugin that the host hadn’t upgraded to PHP5!

    So that’s my guess as to the fatal error and my recommendation to others having this problem… get your host to upgrade their system. Geesh, PHP4 is SO 2008.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP-reCapatcha] incompatible with v3.1.1’ is closed to new replies.