WP-PrettyPhoto 1.6.2 Broken WP 3.1 (9 posts)

  1. Joe Streno
    Posted 4 years ago #

    WP-PrettyPhoto 1.6.2 has stopped working since upgrading to WordPress 3.1 yesterday. I had to deactivate PrettyPhoto & install WP-Slimbox2 (not that I wanted to). Please update soon ...PrettyPhoto is what I want to use not SlimBox.


  2. twinklewitch
    Posted 4 years ago #

    Yeah, broken here as well. Hope it gets fixed soon because I love PP a lot!

  3. bluprojekt
    Posted 4 years ago #

    I ran into the same problem - here's the info I found to resolve it:

    If you have updated WordPress to version 3.1 there will be a problem with JavaScript because version 3.1 uses jQuery 1.4.4 and WordPress 3.0 uses jQuery 1.4.2.

    To fix this you must go to the Pretty Photo site and download the latest version of Pretty Photo – version 3.0.1. Then do the following:
    1. overwrite file jquery.prettyphoto.js in folder /lib/js/
    2. in folder /css/pphoto/ delete all subfolders and overwrite prettyphoto.css file
    3. into folder css copy folder images from unzipped prettyphoto ZIP file

    All I did was step 1 and it resolved my issues.


  4. twinklewitch
    Posted 4 years ago #

    Hey, thanks!

    I solved it by selecting "Replace WordPress' jQuery with bundled version" in the settings. Seems to work fine now as well!

  5. studioactiv8
    Posted 4 years ago #

    I used bluprojekt's approach very good.
    I did have to turn off the thumbnails.
    overlay_gallery: false,

  6. Joe Streno
    Posted 4 years ago #

    Yeah I had tried all that earlier, before posting here. But still couldn't get it to work, so I've tarted up WP-Slimbox2 ... changed all the backgrounds to black, redid all the buttons. Now it looks better. Not WP-pP but tolerable. ; )

    And so it goes ....

  7. tonyzeoli
    Posted 4 years ago #


    I've followed your instructions, but I still can't get WP PrettyPhoto to work properly.

    I get a spinning circle looking for the picture.

    We're using it in conjunction with NextGen Gallery.

    I've add the REL="wp-prettyPhoto attribute in NextGen. I swapped out the files as you recommend. Still nothing.

    Quite confounding. Anyone have any suggestions?


  8. Bozz
    Posted 4 years ago #

    thanks for posting the solution, really helpful! I used twinkewitch's method and it started working again

  9. dRachmad
    Posted 4 years ago #

    If you are looking for wp-prettyphoto 1.6.2 that compatible with WP 3.1.1
    you can try download it from my site tarbak.com - here
    It is still under modification, but for photo it should works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic