Conflict with YARPP - wp-admin broken (7 posts)

  1. Halibutt
    Posted 3 years ago #

    Cross post from here

    Following the recent update to YARPP, my cockpit suddenly stopped working. It seems there is some conflict between WP-PostRatings and YARPP. I can have one or the other, but not both at the same time. Any time I try to activate both, my wp-admin panel stops working at all (blank screen). Any ideas how to resolve the problem?


  2. @Halibutt: Thanks for bringing this to my attention. I just tried installing the WP-PostRatings in a test install, but didn't run into any immediate issues... could you check your server error log to see if PHP is printing any errors? Most likely there is some PHP error resulting in the white screen.

  3. Halibutt
    Posted 3 years ago #

    Thanks for responding so fast. Hopefully we'll find some solution. Take note however, that I'm close to being code-illiterate (I do most of my coding by trial and error, so speak with capital letters to me, as we say here in Poland. :)

    Here are the cPanel error logs, YARPP enabled, trying to enable WP-PostRatings or WP-pagenavi, result the same:

    [Tue Sep 25 10:24:10 2012] [error] [client] PHP Fatal error:  Allowed memory size of 67108864 bytes exhausted (tried to allocate 523672 bytes) in /home/halibutt/public_html/wp-content/plugins/yet-another-related-posts-plugin/class-admin.php on line 57, referer: http://halibutt.pl/wp-admin/plugins.php?activate=true&plugin_status=inactive&paged=1&s=
    [Tue Sep 25 10:21:50 2012] [error] [client] PHP Fatal error:  Allowed memory size of 67108864 bytes exhausted (tried to allocate 523672 bytes) in /home/halibutt/public_html/wp-content/plugins/yet-another-related-posts-plugin/class-admin.php on line 57
    [Tue Sep 25 10:20:45 2012] [error] [client] PHP Fatal error:  Allowed memory size of 67108864 bytes exhausted (tried to allocate 523672 bytes) in /home/halibutt/public_html/wp-content/plugins/yet-another-related-posts-plugin/class-admin.php on line 57, referer: http://halibutt.pl/wp-admin/plugins.php?plugin_status=inactive

    So it refers to the following lines in the class-admin.php:

    // new in 3.3: load options page sections as metaboxes

    67108864 bytes seems like... well... way too much. Until now I've been using the same combination of plugins for years now, including the two (three actually) I'm unable to turn on simultaneously right now. There must be something new.

    My (loaned) server data is (Polish captions, but you'll get the picture):

    Serwer: Localhost via UNIX socket
    Wersja serwera: 5.1.63-cll
    Wersja protokołu: 10
    Kodowanie napisów dla MySQL: UTF-8 Unicode (utf8)
    Wersja klienta MySQL: 4.1.22
    Rozszerzenie PHP: mysql Dokumentacja
  4. Halibutt
    Posted 3 years ago #

    In case you needed it, here's a list of currently active plugins on my site. Those three mentioned before crash wp-admin even if I disable all the rest, but I'm posting just in case.

    Exclude Pages from Navigation
    Get Recent Comments
    Google Analytics for WordPress
    Jetpack by WordPress.com
    Lightbox Plus
    Picasa Album Uploader
    PJW Query Child Of
    Wordpress Download Monitor
    WPML Multilingual CMS
    Yet Another Related Posts Plugin

    All except for WPML are at latest versions. So is the WP itself.

  5. Thanks for the details. I made a modification in this new beta... please see if it fixes the issue for you.


  6. Halibutt
    Posted 3 years ago #

    Thanks, all works fine now :) The memory requirements are much lower for all my plugins now.

  7. Amazing! Great! I'll push out 3.5.4 officially soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.