Support » Plugin: WP-Polls » [Plugin: WP-Polls] 2.63 and its move to using wp-admin/admin-ajax.php breaks protected wp-admin

  • Resolved archon810

    (@archon810)


    Hey Lester,

    I’m using a .htpaccess auth for wp-admin, and the upgrade to 2.63 broke all voting – it now sends a request to wp-admin/admin-ajax.php, which returns 401 Authorization Required.

    I believe no user-facing non-admin plugin should ever access wp-admin – wp-admin should be reserved for when you’re on wp-admin already. Using .htaccess protection is a common anti-hacking technique, so I believe more people will be affected.

    I have to revert to 2.62… except you didn’t tag it in svn. I’ll just restore a backup 🙁

    Hope you can fix it in the future.

    Thanks.

    http://wordpress.org/extend/plugins/wp-polls/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: WP-Polls] 2.63 and its move to using wp-admin/admin-ajax.php breaks protected wp-admin’ is closed to new replies.