Support » Plugin: WP-Piwik » [Plugin: WP-Piwik] Tracking filter not displaying roles on tracking tab

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author braekling

    (@braekling)

    Hm, looks fine here.

    Are you using a plugin which makes changes to your auth roles?

    Are you using another plugin which shows the configured roles? Does this one work?

    I’m not using any plugins that modify user roles. None of my other plugins display roles, but bbpress does add some roles. The default users panel in wordpress displays the user roles just fine. I am using WP in multisite mode.

    Plugin Author braekling

    (@braekling)

    Sorry, I’m not able to reproduce this issue.

    Can you enable WordPress’ debug mode (and PHP error messages) and look for messages?

    I finally figured this one out, and it was a doozy. It turned out to be an issue with my DB and not this plugin. I will go ahead and outline my fix anyway just in case someone else runs into this issue.

    In the pre_options table for the main site in the network, there were entries for both pre_users_roles and wp_user_roles. wp_user_roles contained all the data and pre_user_roles was empty. I deleted pre_user_roles and renamed wp_user_roles to replace it and viola, everything worked.

    Note:for this example the custom wp table prefix is pre_

    Plugin Author braekling

    (@braekling)

    Great you got behind this 🙂

    Thank you for posting your solution!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP-Piwik] Tracking filter not displaying roles on tracking tab’ is closed to new replies.