Support » Plugin: WP-Piwik » [Plugin: WP-Piwik] Piwik did not answer HELP

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author braekling


    FIRST OF ALL: Please remove your auth token here. It allows everybody to access your Piwik installation.

    Maybe there are limitations in your .htaccess (Piwik directory)?

    Examples: User agent filter (to disallow bots), IP filter (no access from localhost)

    What does WP-Piwik say about fopen and cURL?

    i do apologise for this mistake

    i have checked the .htaccess and there is nothing in the file, it is blank.

    # BEGIN WordPress

    # END WordPress

    Either allow_url_fopen has to be enabled or cURL has to be available:

    cURL is available.
    allow_url_fopen is enabled.

    What should i do now?

    Plugin Author braekling


    You posted your WordPress .htaccess, not your Piwik .htaccess.

    Check also your Apache settings (e.g. the Piwik installations vhost.conf).

    Maybe you are using a service like the firewall explained here:

    Plugin Author braekling


    By the way: Your auth token is still shown above. Remove it to keep your Piwik secure (or… better way: Create a new token!) 😉

    How do i edit my orignal post?

    and i can not find the 2 fiels you mentioned. the piwik domain i have created has no htaccess file in it. and where is the vhost.conf file located

    Plugin Author braekling


    Hmmm… I have no idea how to edit your post. I’m sure this was possible in the past. Just renew your auth token – it’s the most secure way.

    “vhost.conf” was an example file name. It depends on your configuration. Have a look in your Apache config – maybe “/etc/apache2/sites-enabled” contains useful information.

    For any reason your server seems to not respond to a request by itself.

    I’m working on a new version also using the PHP API instead of the HTTP API, but currently I can’t tell you when it’s done :/

    Plugin Author braekling


    (Obviously it is only possible to edit “fresh” posts as I see.)

    I do not have access to apache on my web hosting, not sure why

    how can i reset my token???

    Plugin Author braekling


    To change your auth token, just change your password:,76900

    Did you upgrade to Piwik 1.8.2 just before the error appears?

    Plugin Author braekling


    If you can’t access your Apache config, maybe you can access your error logs?


    I’ve been playing around with this and ran the test script. Test 2/2 failed and returned a 403 with a 404. I put the link that test was calling into the browser and got the same result, but when I deleted the preceding http:// from the url argument it worked.

    I then changed every occurrence of:
    str_replace('http://', '', get_bloginfo('url'))
    and it did the trick.

    I know this is a temporary hack, but I might give you a clue in what’s wrong. To me, it seems like a change in arguments to Piwik API. Hope you fix this error soon.


    Plugin Author braekling


    Hi gligoran,

    first of all: Thanks for debugging!

    What does “a 403 with a 404” mean? Did your server return 403 (Forbidden) or 404 (Not Found)?

    I don’t think Piwik arguments changed, because…

    1. in most cases it works fine without removing the HTTP.
    2. Piwik handles URL differences very well (e.g. additional slashes) normally.
    3. Piwik would return an error result instead of “Forbidden” or “Not Found”.

    But I’ll have a look at this and I’ll try your change to check its impact, maybe I get a hint.

    Are you using a firewall service like this? Maybe your server does not allow a “http” in a parameter string?

    403 with a 404 means that the server returned 403, but said some 404 occurred as well. The first time I saw it too, thought it might mean something.

    Anyway, after posting this I noticed that even the Piwik’s own JS tracking code isn’t working properly. So I posted this:,90097,90121. Apparently my hosting provider (HostGator) has mod_security enabled, which rejects http:// in the links with a 403 error. I haven’t yet figured out how to bypass this, but will post here, when I do. This means that neither WP-Piwik or Piwik itself aren’t to blame, but it also means that a lot of people will have problems, as HostGator is one of the biggest hosts around.

    Plugin Author braekling


    Just try the “avoid mod_security” option in WP-Piwik. This should work for your case.

    To solve your problem for all of your sites, mod_security allows you to create a whitelist. I have no further information on this, but I know about some HostGator users who work with such a whitelist and Piwik successfully.

    Plugin Author braekling


    @ jiteshpatel: Are you using mod_security, too? Can you also try to enable “avoid mod_security”?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: WP-Piwik] Piwik did not answer HELP’ is closed to new replies.