WordPress.org

Support

Support » Plugins and Hacks » WP-Piwik » [Resolved] [Plugin: WP-Piwik] permission issue

[Resolved] [Plugin: WP-Piwik] permission issue

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author braekling

    @braekling

    Which tab are you saving? Can you check your setting tab’s URL and the URL showing the error message – and post both here (the part behind /wp-admin/)?

    I’m quite sure this is caused by requesting a wrong PHP script (options-general.php instead of network/settings.php). In this case it should be easy to fix this bug after you answer my questions above.

    Br
    André

    wp-admin/network/settings.php?page=wp-piwik/wp-piwik.php&tab=piwik

    I get this error with all tabs (tracking,settings,statistics…)

    Plugin Author braekling

    @braekling

    You get this URL both times? (opening the tab & after saving your settings)

    If so it seems to be a more complex problem. This evening I’ll try to reproduce the issue.

    Earlier WP-Piwik versions worked fine?

    yes, older versions was working fine. I’ve sent email to you for some request about this plugin. Can you check please.

    Thanks for helping.

    Plugin Author braekling

    @braekling

    Hm… I currently have no idea how to reproduce this error without changing the form’s target URL.

    Let’s try this:

    1. Open network admin -> settings -> WP-Piwik
    2. Choose tracking tab
    3. Post the current site’s URL here (URL 1)
    4. Click at “Save settings”
    5. Post the current site’s (= error site) URL here (URL 2)

    And one more test:

    1. Open network admin -> settings -> WP-Piwik again
    2. Choose support tab
    3. Click at “Get site configuration details”
    4. Do you get an error site, too?
    5. Post the current site’s URL here (URL 3)

    Correct behaviour would be:

    – No error site (of course)
    – URL 1: /wp-admin/network/settings.php?page=wp-piwik/wp-piwik.php&tab=tracking
    – URL 2: /wp-admin/network/settings.php?page=wp-piwik/wp-piwik.php&tab=tracking
    – URL 3: /wp-admin/network/settings.php?page=wp-piwik/wp-piwik.php&tab=sitebrowser

    One more question: Are you using any plugin changing permissions, admin page URLs, or something similar?

    I’ll answer your mail later this day.

    Plugin Author braekling

    @braekling

    Anything new on this?

    I made some minor changes regarding URLs in 0.9.4 – maybe your issue is solved now?

    When I tried to save new method (Piwik path (PHP API, beta)) I didn’t get this error.

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: WP-Piwik] permission issue’ is closed to new replies.
Skip to toolbar