WordPress.org

Forums

WP-Piwik
[resolved] No Site added to Piwik when creating Site with empty Site Title (5 posts)

  1. moepstar
    Member
    Posted 3 years ago #

    Hi,

    with WP Piwik Network Activated it seems that there isn't a site being created once you add a new one in the Multisite Network Admin.

    The error message in the child-blog (subdomain) is:

    Piwik error: The requested website id = 0 couldn't be found

    Visiting the frontpage of the newly created site in logged in and logged out browsers doesn't seem to help either, neither does retroperspectively adding the site title change anything - the site doesn't seem to exist as far as Piwik is concerned.

    Any kind of ideas on how to resolve that, short of deleting the site and recreating it?

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Site name seems to be a required parameter if a new site is created by Piwik API. Maybe I can solve this by adding some kind of default value (i.e. the blog's URL). I'll keep this in mind as a major bug and will try to fix it soon.

    To solve this in your case, you should remove the WP-Piwik settings regarding this blog. If there are no settings stored, WP-Piwik tries to get the site's ID by Piwik... or it will create a new one :)

  3. moepstar
    Member
    Posted 3 years ago #

    Thanks for taking this seriously :)

    Do you have an idea which database tables/rows i'd need to look out for or even should delete?

  4. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    If you know the blog's ID (WP ID, not Piwik ID), try this to find all WP-Piwik related site-specific settings:

    SELECT * FROM wp_BLOGID_options WHERE option_name LIKE "wp-piwik_%" OR option_name LIKE "wpmu-piwik_%"

  5. moepstar
    Member
    Posted 3 years ago #

    Thanks - i've figured it out myself in the meanwhile, marking this resolved for now :) Hopefully the info is useful for others who might have the same problem :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Piwik
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags