WordPress.org

Forums

WP-Piwik
[resolved] Disable cookies: Disable all tracking cookies for a visitor does not seem to wor (8 posts)

  1. Joost
    Member
    Posted 2 years ago #

    Hi,

    It seems that the option "Disable cookies: Disable all tracking cookies for a visitor." doesn't work. At least, ghostery does still detect the Piwik tracking cookie.

    Or am I missing something here?

    Regards,
    Joost.

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Please have a look at your tracking code. Does the following line appear?

    piwikTracker.disableCookies();

    Did you clear your browser's cookies before testing?

  3. Joost
    Member
    Posted 2 years ago #

    Sorry for my late reaction, I did not receive a notification of your comment.

    I see the script code in the html, but ghostery still reports a tracking cookie.

    I am using piwik 1.8.2.

  4. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    I had a look at my own blog and it seems to be fine. Does the line appear before piwikTracker.trackPageView()?

    Did you clear your cache?

    Are you sure the reported tracking cookie was set by your Piwik tracking code? (Maybe it's another site's tracking code? Maybe it is your Piwik dashboard login cookie or something similar?)

    If you are sure your Piwik still creates a cookie although the tracking code is modified correctly by WP-Piwik, please report this to the Piwik team: http://forum.piwik.org

  5. Joost
    Member
    Posted 2 years ago #

    I logged out, removed all the cookies. But still the cookie appears. And yes, I am sure there is no other site involved... I will cross-reference with the code from your site.

    This is the generated code, by the plugin:

    <script type="text/javascript">
    var pkBaseURL = (("https:" == document.location.protocol) ? "https://analytics.sargasso.nl/piwik/" : "http://analytics.sargasso.nl/piwik/");
    document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
    </script><script type="text/javascript">
    try {
      var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);
      piwikTracker.disableCookies();
    piwikTracker.trackPageView();
      piwikTracker.enableLinkTracking();
    } catch( err ) {}
    
    </script><noscript><p><img src="http://analytics.sargasso.nl/piwik/piwik.php?idsite=1" style="border:0" alt="" /></p></noscript>
    <!-- End Piwik Tracking Code -->
  6. Joost
    Member
    Posted 2 years ago #

    Exactly the same code as on your site, and ghostery does not report a tracking cookie there. Are you using the latest Piwik version?

  7. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    I'm using the latest stable (1.8.2). You are not using "js/index.php", please activate this in tracking settings and try again.

    Please report your issue to the Piwik team, even if activating js/index.php works. So they can have a look at this issue and maybe fix it.

  8. Joost
    Member
    Posted 2 years ago #

    Yes, that was it! Will report it to the Piwik team. Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP-Piwik
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic