Support » Plugin: WP Photo Album Plus » [Plugin: WP Photo Album Plus] Upgraded plugin, broke plugin

  • Resolved Dark Rubes


    I upgraded the photo album plugin the other day, and now I can’t upload or import photos. It worked beautifully until I upgraded it. The error I get is:
    Could not insert photo. query=INSERT INTOwp_wppa_photos(id,album,ext,name,p_order,description,mean_rating,linkurl,linktitle,timestamp,owner) VALUES ('47', '8', 'png', 'MomWiiSports9.png', '0', '', '0', '', '', '1317026561', 'GI-archives')

    After that message, I receive the standard notification of “1 Photos Uploaded in album nr 8”. This happens whenever I try to upload them individually or using the import photos. Interestingly enough, I can still create new albums and edit old ones. I can’t upgrade my WordPress from 3.2 to 3.2.1 because I am running MySQL 4.1.4. My hosting provider is not up to MySQL 5, so I can’t upgrade that.

    HELP! I need a simple fix for this to continue using it. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • A minor update but something that might make a difference: I am running 3.0.4, not 3.2 WordPress.

    Plugin Author Jacob N. Breetvelt


    Is there really no space between INTO and wp_wppa_photos in the errormessage? If so, re-install the plugin, one of the files is corrupt.

    Else: run setup (Table VIII item 3) and try again.

    If still nothing do the following:

    • Check Table IX item 5.
    • Go to the upload page
    • append &debug to the adressline in the browser and press enter
    • upload a photo and watch the errormessages

    OK, there was a space in the first error message so that’s not the problem. I’d already run the re-initialize step in Table VIII Item No. 3.

    When I ran the debug, the message that I got was:
    [WPPA+ dbg msg: Lastkey in wp_wppa_photos = 46]

    I also noticed last night when I looked at my tables in phpMyAdmin that it wasn’t counting all of my albums when I looked at the photo list. I have 8 albums, 7 of which have photos in them and no. 8 is the one that I just tried to create this morning and add photos. I don’t think I have the problem with the maximum value ID as someone else had in another post. I looked at the values and they are all normal.

    I also determined that I upgraded from 4.0.10 to the newest version, if that helps. I installed a version on Aug. 26 and upgraded two days ago the newest version.

    UPDATE: I managed to fix the problem by downgrading to the original version that I started with. Once I did that, I could use the plugin again with no problems. It’s probably that the new version (4.10) is not meant to be used with an older version of WP since I can’t upgrade it.

    Plugin Author Jacob N. Breetvelt


    The debug trick you did (correctly, thank you) should have given any (sql) error/warning message, but it didn’t unfortunately.
    The only change in adding an album i made (in version 4.0.12) was fixing awarning that i entered two zeros where strings were expected, and i changed them to strings, so nothing substantial.

    Would love to see an errormessage, but should not know how to get that. The debug trick is as strong as define( 'WP_DEBUG', true ); in wp-config.php.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: WP Photo Album Plus] Upgraded plugin, broke plugin’ is closed to new replies.