WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: WP Photo Album Plus] Two important features missing on wppa albums plus

[Resolved] [Plugin: WP Photo Album Plus] Two important features missing on wppa albums plus

  • I have, at last, after over a year, gone Live with my website which has over 2,000 photos in the Arcive, and love my WPPA Plus albums.

    Helen Oppenheim | Hair Fashion Photo Archives

    But
    now find there are two important features missing and, since I am doing and planning
    on doing a lot of press on my website, right now, and into the New Year, and since many others must have the same important features missing, I would like to request two fixes as soon as possible, which will make your albums even more successful.

    1. Sharing Photos; This is the age of Social Media, and when I, or anyone, wants to Share one particular photo or one album on, say, Facebook, the whole category appears on Facebook, not just the one photo or the one album. Some of my categories have over a 100 photos so anyone doing that with photos from the WPPA Plus Albums would be horrified at so many more photos on their pages or website or wherever rather than the one, or the one album, they wanted. Many of my people want to post just one photo.

    2. Comments: I receive no email notification from WPPA Albums Plus when someone posts under my photos, as I do with WordPress Albums on my website, so I can’t approve what anyone says. Apart from the very real possibility of unsuitable comments, In my world, it is rude not to respond to people and I can’t keep checking in your Comments Folder in the Dashboard all day long. I am expecting many Comments so this is a real problem.

    My webmaster is very experienced, he has tried everything to make the above features work but to no avall. They are dysfunctional. Surely everyone would benefit if you fixed the problems?

    With respect, can you give me an idea if you can do this, and when? Both missing features are spoiling the success of my website.

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

Viewing 15 replies - 16 through 30 (of 33 total)
  • FYI Cover photo thumbnail links to album slideshows have suddenly stopped working. Got any clues?

    Ralph

    FYI Cover photo thumbnail links to album slideshows have suddenly stopped working.

    Found it…

    Table VI:
    6a,b,c,d Cover Image: same as link.

    Plugin Author Jacob N. Breetvelt
    Participant

    @opajaap

    Secondly, now that the AddThis share now posts the current image and link correctly I have a new request that AddThis also include the image’s description!

    I will see if the addthis api interface supports this, if so i will do that.

    The link that is shared with Facebook is the link to the actual URL image file and not the album with the image slide displayed which is what would be preferred.

    2. The shared link to go to the album page with the shared thumbnails large image displayed and not the URL to the albums featured image.

    This is (or is it not???) the other link setting ( the expected image visible in the context of the slideshow ). It should also work correctly now. (since 4.7.16).

    I have adjusted the previous and next width sizes with CSS to help keep people from easily dragging or exposing the photo URL

    It used to be 2 times half the area, indeed also to help proventing copy. BUT there are plugins that prevent from copying ( like “copy protect” ) that work much better than fiddling around with css.

    BTW COULD WE PLEASE LIMIT ONE THREAD TO ONE TOPIC PLEASE

    FYI Cover photo thumbnail links to album slideshows have suddenly stopped working. Got any clues?

    BTW COULD WE PLEASE LIMIT ONE THREAD TO ONE TOPIC PLEASE

    Thanks for your quick response!

    The setting below does share the correct current image. If we can get the images description and the link to the album with the images large photo displayed, that would be great.

    Table IX: Miscellaneous:
    F3
    Share type set to: The page with the photo

    Thanks,

    Ralph

    Plugin Author Jacob N. Breetvelt
    Participant

    @opajaap

    Pleas explain. The display is correct though? or do you want the image alone in the page, so, not with the entire slidshow behind it? (Is rather easy doable)

    Let’s say you are in an album and are viewing slide number three. right now when you share to Facebook the correct image thumbnail (number three) is shared but the link back to the album displays the album cover image as the main slide and not number three.

    I realize that there is not a unique URL for the album displaying slide number three and that is what would be ideal for a return link on Facebook posts for a specific slide with it’s description.

    So, when people are disusing a particular photo slide the link on Facebook will take them to that slide in the album and not the beginning of the album slideshow.

    I hope this helps,

    Ralph

    Plugin Author Jacob N. Breetvelt
    Participant

    @opajaap

    Let’s say you are in an album and are viewing slide number three. right now when you share to Facebook the correct image thumbnail (number three) is shared but the link back to the album displays the album cover image as the main slide and not number three.

    That is NOT the intention. You should see the slideshow with the selected image insight….

    I realize that there is not a unique URL for the album displaying slide number three and that is what would be ideal for a return link on Facebook posts for a specific slide

    Yes, there is. I wonder why it does not work on your site…

    When i click on the 3rd slide in the appropriate album, the console log says:

    [17:16:52.298] AddThis share url update to http://www.helenoppenheim.com/ny-fashion-week/ny-fashion-weekfall-2012-albums/?locale=en_US&wppa-album=132&wppa-photo=1322&wppa-cover=0&wppa-occur=1 succeeded @ http://helenoppenheim.com/wordpress/wp-content/plugins/wp-photo-album-plus/wppa.js?ver=3.4.2:2099
    [17:16:52.299] AddThis share title update to 3  Carolina Herrera F/W12 succeeded @ http://helenoppenheim.com/wordpress/wp-content/plugins/wp-photo-album-plus/wppa.js?ver=3.4.2:2107

    The link http://www.helenoppenheim.com/ny-fashion-week/ny-fashion-weekfall-2012-albums/?locale=en_US&wppa-album=132&wppa-photo=1322&wppa-cover=0&wppa-occur=1 gives me the slideshow with the correct image in sight… so….????

    Hmmm, using Firefox or Chrome when I go to that album, starting from the home page via the top menu, I get this:

    http://www.helenoppenheim.com/ny-fashion-week/ny-fashion-weekfall-2012-albums/?locale=en_US&wppa-album=132&wppa-slide&wppa-occur=1#.UHWUZVH66tM

    I have noticed since the last update that this and similar codes is appearing at the end of all URL’s: #.UHWUZVH66tM

    I tried both logged in and logged out and the result is the same. So,it is working for you? What browser are you using?

    Plugin Author Jacob N. Breetvelt
    Participant

    @opajaap

    I did some more investigation and found:

    I would like you to take a look at: http://wppa.opajaap.nl/my-album/?locale=en_US&wppa-album=4&wppa-photo=8&wppa-cover=0&wppa-occur=1 and hover over the red Share button, to see the addthis selection box apears. Then, navigate to another slide, and hover over the red Share button. The selection box appears, and i can send an email with the right link.
    The console log tells me:

    [13:12:22.532] AddThis share url update to http://wppa.opajaap.nl/my-album/?locale=en_US&wppa-album=4&wppa-photo=23&wppa-cover=0&wppa-occur=1 succeeded @ http://wppa.opajaap.nl/wp-content/plugins/wp-photo-album-plus/wppa.js?ver=3.4.2:2099
    That is RIGHT.

    At this point my conclusion is: the cause that it does NOT function on your site is either in the theme or an other plugin.

    Try to fix the two errors at the top of this reply, disable all other plugins temporarely (except addthis and wppa) and/or temporary switch to a different theme (e.g. twentyten is ok)

    BTW: Do not worry about #.UHWUZVH66tM too much, it is probably some extra info for a plugin or the theme, it should be harmless and not causing our problem.

    Reset Colaborate-Thin_400.font.js js to 400 from bold.

    Turned off all plugins except WPPA and ShareThis, switched to Twenty Ten, dumped cache and refreshed.

    No change. Will keep tinkering.

    Thanks,
    Ralph

    PS Donation for your efforts coming soon!

    I did find these and others in the DOM console…

    [undefined, [“http://www.helenoppenhe…pa-cover=0&wppa-occur=1”, “http://www.helenoppenhe…pa-cover=0&wppa-occur=1”, “http://www.helenoppenhe…pa-cover=0&wppa-occur=1”]]

    [undefined, [“http://helenoppenheim.c…nt/uploads/wppa/887.jpg”, “http://helenoppenheim.c…nt/uploads/wppa/885.jpg”, “http://helenoppenheim.c…nt/uploads/wppa/884.jpg”]]

    Plugin Author Jacob N. Breetvelt
    Participant

    @opajaap

    I tried to further investigate, but you disabled addthis…

    Yeah, she has to many very important people viewing the site and unable to use AddThis correctly while she is doing a massive publicity campaign that she asked me to disable it. There is something wrong with here installations that I can’t track down. I am a Drupal guy!

    Thanks anyway,

    Ralph

    Plugin Author Jacob N. Breetvelt
    Participant

    @opajaap

    Please fix this error:

    In wp-content/theme/Envisioned/js/Colaborate-Thin_400.font.js it reads:

    /*!
    * The following copyright notice may not be removed under any circumstances.
    *
    * Copyright:
    * Copyright (c) 2003 by This Font is designed by Ralph Oliver du Carrois. All rights reserved.
    *
    * These files are part of the free font collection offered by Carrois Type Design GbR. …..etc….
    *
    */
    Cufon.registerFont({“w”:165,”face”:{“font-family”:”Colaborate-Thin”,”font-weight”:bold,”font-stretch”:”normal”,”units-per-em”:”360″,”panose-1″:”2 0 5 6 ….etc….

    Change bold in “bold” (see the bold bold above) i.e. surround bold with doublequotes.

    My computer had a complete melt down and I have to reload everything. I will get to this when I can.

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘[Resolved] [Plugin: WP Photo Album Plus] Two important features missing on wppa albums plus’ is closed to new replies.