WordPress.org

Support

Support » Plugins and Hacks » WP Photo Album Plus » [Plugin: WP Photo Album Plus] Plugin works very slowly

[Plugin: WP Photo Album Plus] Plugin works very slowly

  • Dear opajaap

    first of all thank You very much for your wonderful plug-in, the best gallery plug-in for WP on mine mind.

    Unfortunately I get some problem with it.
    The plug-in works very slowly, both for showing pictures and for import.
    I must wait about 45 second for showing a slide-show of an album with 65 pictures.
    The import of every picture needs about 10 seconds… (picture are already on the server, uploded via ftp, the are about 60 kb big)
    Diring import I get for every picture a warning:

    .
    Warning: unlink(/homepages/6/d29901406/htdocs/orangesky/wp-content/wppa-depot/orangesky/03.09.11/030911_20.jpg) [function.unlink]: No such file or directory in /homepages/6/d29901406/htdocs/orangesky/wp-content/plugins/wp-photo-album-plus/wppa-upload.php on line 677

    I use WP 3.3.1, your plug-in has version 4.4.8

    I have to import in my site about 90 albums with 17.000 pictures. It would be grateful if You can help me.
    Thank in advance
    Sergei
    P.S. can I write to You in German as well?

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jacob N. Breetvelt

    @opajaap

    1. Your english is very good to read for me. My native language is dutch,
    i am afraid i will understand german less than your english, so please keep it english.

    2. The warning message at line 677 may be ignored, it does no harm and will be removed in the next version. (the temp file is already deleted there).

    3. I am afraid that your server is very slow (old?). Please check Table IX-5 (WPPA+ debugging) in the Photo Albums->Settings admin page, and supply a link to your site (to the page with the slideshow), then i can see more.

    Hello opajaap,

    thamnks a lot for your answer. My server is actualy not slow, its a virtual server by 1 and 1.
    Hiere is the link to one of albums: http://orangesky.faktorov.de/fotos/?wppa-album=42&wppa-cover=0&wppa-occur=1

    I have activated WPPA+ debugging.

    I think the problem is, that the script loads all photos of the album befor the first of them will be displayed, so if the album has about 100 photos or more it nead a very lot of time. A litle album (30 photos) works very good! Can I do something?

    Plugin Author Jacob N. Breetvelt

    @opajaap

    The script loads the photos at the moment they are displayed, so that is not the problem.

    Append &debug to the link. You will see this on the slideshow page:

    [WPPA+ dbg msg: %%wppa%% found]
    [WPPA+ dbg msg: Text: %%wppa%%
    
    [WPPA+ dbg msg: Doit is on]
    [WPPA+ dbg msg: Time elapsed occ 1:98.07s. Tot:98.07s.]

    This means that the php to create the slideshow takes 98.07 seconds.
    That is very much!

    Try this (on my private site):

    Foto album

    You will see that the slideshow of 349 photos takes only 0.072 seconds server time.

    [WPPA+ dbg msg: %%wppa%% found]
    [WPPA+ dbg msg: Text: %%wppa%%
    
    ]
    [WPPA+ dbg msg: Doit is on]
    [WPPA+ dbg msg: Time elapsed occ 1:0.072s. Tot:0.072s.]

    Maybe the use of much server memory causes the sever to do exessive paging?
    Check the server memory, it should be able to use at least 64MB without paging.

    I’ve found the problem. The database and the server are OK, but the plugin creates a tremendous amount of unnecessary code!
    If Filmstrip is active, all the thumbnails are pre-loaded before the page is displayed. Thus, the size of the files that are displayed on one side, about 7 mB! In addition, there are approximately 2,000 lines of html on the site on which the images are displayed in full size. … It is no wonder that the page takes so long.
    Another problem is that the plugin generates a lot of unnecessary code.
    I turned off everything – rating, comments, IPTC and EXIF – despite of this about 38.000 the code is generated for each image:

    /* <![CDATA[ */

    Am I doing something wrong? What can you do to improve this situation?

    … may be you can have a look on source code hier: http://orangesky.faktorov.de/fotos/?wppa-album=41&wppa-photo=2158&wppa-occur=1

    Plugin Author Jacob N. Breetvelt

    @opajaap

    Pls update to 4.5.0, it will no longer create html for exif and iptc and comments if it is switched off. This should help. It also uses thumbnail images wherever possible (if the requested size is not bigger than the avail thumbs.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: WP Photo Album Plus] Plugin works very slowly’ is closed to new replies.
Skip to toolbar