Support » Plugin: WP Photo Album Plus » [Plugin: WP Photo Album Plus] Latest Update causing Fatal Error

  • Resolved Emmageddon

    (@emmageddon)


    Plugin could not be activated because it triggered a fatal error.
    
    Parse error: syntax error, unexpected T_ELSE in /home/content/11/8493711/html/wp-content/plugins/wp-photo-album-plus/wppa-common-functions.php on line 589

    Hello I just pressed update for the latets version of the plugin and got the above error message.

    Please help (not had a lot of help across the WordPress forums with my past requests) as I really love this plugin and the userbility of it and have my clients site going live in 9 days.

    I have tried turnign off all other plugins, I have tried deleting this and starting again but I still get this error message.

    Thank you in advance

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

Viewing 15 replies - 1 through 15 (of 46 total)
  • I have gotten this same error this morning. It took my site down completely. I use this plugin in my other sites as well and am afraid to use it now. I can’t believe you would release an update that is this flawed.

    This plugin was brilliant and served all my needs especially as I need a site which users will add content to. Can’t believe the plugin came out flawed so bad.

    Crazy that they shipped a syntax error, for sure. Thankfully the fix is easy. Remove line 588 from wppa-common-functions.php and it will work once again.

    (this applies to version 4.3.6)

    Awesome. Thanks for the fix!

    Will have to give that a try when I get home (just leaving) and can get plugged in again – thank you in advance (fingers crossed)

    Would still be interested to see if the develop will do a fix though because there will be a lot of people out there finding same problem

    What is the code on 588 ? is it

    break;

    ???

    No, line 588 has a single curly brace on it: }. The preceding two lines are commented out, and it appears that the author just failed to also comment out that line.

    After deleting line 588, the working function looks like this:

    function wppa_qtrans($output, $lang = '') {
      if ($lang == '') {
        $output = __($output);
    //  if (function_exists('qtrans_useCurrentLanguageIfNotFoundUseDefaultLanguage')) {
    //  $output = qtrans_useCurrentLanguageIfNotFoundUseDefaultLanguage($output);
      } else {
        if (function_exists('qtrans_use')) {
          $output = qtrans_use($lang, $output, false);
        }
      }
      return $output;
    }

    Thanks for the fix! Worked like a charm after I had the same error 🙂

    Way to go sant0sk1…You da man!

    Thanks! that fixed it!

    sant0sk1 – brilliant, brilliant, brilliant! Thank you so much!

    As others have mentioned though I am not going to put my thread to solved as I still think the plugin maker needs to rectify the problem his end and restore what is a great plugin.

    Thanks

    Thank you so much for the fix – I nearly freaked out when I thought I had lost my albums!

    My page does not open at all and it displays this message
    wp-content/plugins/wp-photo-album-plus/wppa-common-functions.php on line 589

    what do i do?

    in tried the above and now i am getting tis message, any helpppppppp

    Fatal error: require_once() [function.require]: Failed opening required ‘wppa-common-functions.php’ (include_path=’.:/usr/lib/php5′) in /homepages/41/d383435300/htdocs/wp-content/plugins/wp-photo-album-plus/wppa.php on line 55

    thanks once again sant0sk1 – another site rescued.

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘[Plugin: WP Photo Album Plus] Latest Update causing Fatal Error’ is closed to new replies.