Support » Plugin: WP Photo Album Plus » [Plugin: WP Photo Album Plus] Could Not Create Album

  • Resolved svetoslavd79

    (@svetoslavd79)


    Hi,

    I just installed WP Photo Album plus and for some reasons can not create any Albums. I keep getting “Could not Create Album”. The same happens with WP Photo Album. Should I just delete one of the plugins?

    Please help!

    regards
    SD

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Delete WP photo album. You can not have them both at the same time.
    after the delete, do a de-activate and activate of wp photo album plus.
    Then: try again.

    Did you change the database prefix?

    yes I did change DB prefix. i am guessing that this is the issue as I tried installing it on other websites of mine but still no luck.

    Please help
    SD

    I tried the WP PA Plus and WP PA. None of them will allow me to create albums. The + version at least tells me that it can not add. the WPPA tells me Album Added but when i click upload photos it tells me that there are no albums yet. Also the SQL tables are empty.

    I did not see which tables are created when you install WPPA +?

    Thanks again
    SD

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    You obviously do not have the tables.
    They are wppa_albums and wppa_photos (except for the db prefix).

    I made a patch that will check and create and/or update the tables if needed each time you activate the plugin as long as you do not downgrade.

    Do the following:

    de-activate the plugin.
    Delete the plugin.
    Download and install a fresh copy of the plugin.
    Activate it.
    Check the plugins settings panel. At the top you will see the database version number. If this is 191 you are sure the code to create/update the db tables has been executed.
    It should work then.

    You may de-activate and re-activate the plugin in order to retry the db table creation if needed.

    ok the first part seem to have worked. The Database Revision is 191 and when I installed the fresh copy it did create the tables. I am sure coz I made sure the old ones are dropped before I installed it again!

    Now I still get “Could Not Create Album” error – I wish there was something more specific. is there a log that I can look at?

    I am sorry, I wish it was easier, I am sure you have plenty other things to worry about and I really appreciate your help!

    SD

    I finally figured out how to enable WP debug mode and here is the error I got:

    WordPress database error: [Field ‘main_photo’ doesn’t have a default value]
    INSERT INTO mimiwp_wppa_albums (id, name, description, a_order, a_parent, p_order_by) VALUES (0, ‘Test’, ‘Test’, 0, 0, 0)

    And here is how to fix this:

    opent my.ini in folder D:\Program Files\MySQL\MySQL Server 5.0 , or whatever folder
    i changed
    sql-mode=”STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION”
    to
    sql-mode=””

    restart mysql service

    So far everything is working fine. I will report after some further testing!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Thank you for this!

    I will make sure that main photo will have a value in the next rev.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    And at two other locations the same fix

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    The patch has been uploaded and should be available within half an hour.

    Please uninstall and delete the plugin, do a fresh download of the plugin, install and activate, either ‘by hand’ or from the wp plugin admin page.

    This should fix the problem definitive, since all vars have a value now when a table entry is inserted.

    Have the same problem–can’t make any new galleries after creating the first one. Since it’s been months since the last post, I would assume that the recent updates would have fixed this. What should I do to sort this out?

    Found the solution! Simply deactivating, then reactivating the plugin solved it!

    quenth

    (@quenth)

    this bug still exists for me, in wppa 1.5.1

    WordPress database error: [Field ‘main_photo’ doesn’t have a default value]
    INSERT INTO wp_wppa_albums (id, name, description, a_order) VALUES (0, ‘x’, ‘x’, ‘1’)

    The field is not allowed to be Null, but no default value is provided:
    $create_albums = “CREATE TABLE ” . ALBUM_TABLE . ” (id bigint(20) NOT NULL auto_increment, name text NOT NULL, description text NOT NULL, a_order smallint(5) unsigned NOT NULL, main_photo bigint(20) NOT NULL, PRIMARY KEY (id) )”;

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    wppa is a different plugin from a different author and is not supported for two years. It was the basis i used to create wppa+.
    Upgrade to wppa+ (delete wppa and install wppa+) and you will have a huge number of improvements and features as well as continuing support.

    We have multiple albums, on one page called MODS we want to display several albums, the code on the page we see in the instructions is %%wppa%% but this shows all the albums, and on other pages we only want to show certain albums as well not all of them. So my question is: what is the code to put in the page so that only the albums we want to display show up? We tried setting our parent album from “none” to “seperate” but then we dont get any albums to display. Very frustrating to say the least, we did see that puting %%wppa%%%%album=5%% should display only album 5 but instead it shows all abums that parent is marked to none…what can we do to get the albums to display on the pages we want them to? Blog site url below, in case you want to see what I mean. Thanks in advance…Ken

    kcmustain@gmail.com

    http://www.vaperstation.com

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: WP Photo Album Plus] Could Not Create Album’ is closed to new replies.