Support » Plugin: WP Photo Album Plus » [Plugin: WP Photo Album Plus] Changing font family not working?

  • Resolved cajonpeter


    I have tried to change the font-family in the settings but nothing changed.
    Tried css coding and normal names like Arial or family like Arial, Helvetica, sans-serif; with and without ; but I can’t seem to make it change. What’s wrong? I could rewrite the wppa_theme.js and edit the css but I thought I could change the font in the settings.

    Changing the size works OK

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jacob N. Breetvelt


    A link to your site would help me to see what is wrong.
    What specific setting, or all font family settings you have problems with?

    Ok thanks for your reply. The site is set up as an testsite for a client. So it is placed in our own webspace not as a domain yet.
    You can reach it with:

    The Album is the top Photo album in the menu not the child.

    I have tried every font family but I could only change the second level of the breadcrum fonts not the other fonts for navigation etc.

    At this moment I have put in Ariel in settings

    Plugin Author Jacob N. Breetvelt


    Do you have an (old) copy of wppa_theme.php in your theme directory?
    If so, just delete it.

    No I had a copy from the newest version inside the dir. Even if I delete this one, no changes. There are only just a few font changes in Firefox and a few more in IE or Chrome. The first breadcrumb (title of photopage) is non formatted in Firefox and Arial in IE. No browser gives Arial font for the navigation text (next photo/previous photo and photo 1 of …text)

    The boxes for the albums in Firefox are also not formatted but in IE and Chrome they do use Arial.

    Any ideas?

    Plugin Author Jacob N. Breetvelt


    Look at the page source from within firefox and you will see that there is a <tt> that should not be there:

    <div class="postwrap">
          <h2 class="posttitle-page"><a href="">Photo albums</a></h2>
          <div class="postcontent"><p><tt></p>	<div class="wppa-nav wppa-box wppa-nav-text">
    <span class="wppa-black"; >Photo albums</span>	</div>

    I have seen this before, strange themes… This tt tag stayes effective the whole page and overrules your Arial’s that are in place.
    So, find out how to remove the tt tag and it will probably be fixed.

    Note that the <p><tt></p> combination is illegal anyway, so do not expect that different browsers react the same.

    By the way, did you remove class wppa-nav-text from the breadcrumb and leaving a superfluous ; there? see: <span class="wppa-black"; >

    Thanks for looking into this. I found the problem with the tt tag. It was accidentally added when I put in the code for the wppa album. Together with some p tags as well. I forgot to look the HTML. Sorry. When I removed the tt tag the font problem was solved of course. Now all the browsers act the same.

    I did not remove any class from the breadcrumb. Maybe also a result of the HTML that was not supposed to be???

    Plugin Author Jacob N. Breetvelt


    Ok, in the mean time i found the ;
    It is a typo of me, but does no harm.

    Case closed.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: WP Photo Album Plus] Changing font family not working?’ is closed to new replies.