WordPress.org

Forums

WP Photo Album Plus
[resolved] AutoSave creates "The Server returned unexpected output" mes (16 posts)

  1. Marcus Tibesar
    Member
    Posted 3 years ago #

    Hello,

    Every time I AutoSave, I receive the following message:

    "The Server returned unexpected output"

    The message does not seem to interfere with saving - the fields are saved nevertheless.

    I deleted the WPPA+ plugin and then re-installed the WPPA+ plugin but, the message remains.

    Should I be concerned?

    Thank you so much!

    Marcus Tibesar
    [ Signature moderated. ]

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    You should not be concerned. The message is a warning or error that you would also see on an other admin page. It is mostly a message from a different plugin, that is also issued to the ajax operation. It is displayed by my plugin to alert you that there are errors (warnings) in your installation. If the status displayes a proper up[date message (on the album admin page) or you get a green checkmark (on the settings page) all is ok. Maybe you have WP_DEBUG on in wp-config, disabling define('WP_DEBUG', true); in wp-config.php will help

  3. Marcus Tibesar
    Member
    Posted 3 years ago #

    Hello,

    Yes, the status displays that a proper update on the Album Admin page has occurred.

    When I update the Settings I get the unexpected-output message AND I also get the green checkmark. So the Settings are being AutoSaved.

    I checked the wp-config.php file and there is no wp_debug statement.

    Thank you so much!

    Marcus Tibesar
    [ Signature moderated. ]

  4. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    "The Server returned unexpected output"

    The message does not seem to interfere with saving - the fields are saved nevertheless.

    If you tell me what the message is, i might be able to help you finding its cause and fix it...

  5. Marcus Tibesar
    Member
    Posted 3 years ago #

    Hello,

    You are correct; the AutoSave works correctly.

    It is a bit of a hassle though that every time I advance when using Album Admin or Settings, I get this message:

    "The Server returned unexpected output."

    That is the entire message. When I click OK I am able to continue updating the next field within the Album Admin.

    Thank you so much!

  6. wwwebconcepts
    Member
    Posted 2 years ago #

    I have the same error.

  7. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    Does this happen on the album admin only or also on the settings page?

    Do you have define('WP_DEBUG', true); in wp-config? if so, remove it.

  8. patsch27
    Member
    Posted 2 years ago #

    Hello,

    i also suspect that causes other than from WPPA-gallery.
    Error appears now with me, without anything changed in the WPPA-gallery setting or added new gallery.
    How is the work around for the error to delete?

    THX for answer
    patsch27

  9. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    Would be great to know the content of the errormessage...

  10. patsch27
    Member
    Posted 2 years ago #

    1.) Have Update to new Version 4.9.13
    error remains
    2.) Have delete WPPA and reinstall
    error remains
    3.) Have in wp-config.php > ('WP_DEBUG', true);
    see error message I
    4.) Have deaktivate wp-cumulus and heaer-footer-Plugin
    5.) error message is smaller, see error message II.
    But remains "The server returned unexpected output"

    ----------------------------------------------------------
    error message I
    The server returned unexpected output

    <b>Notice</b>: register_uninstall_hook was called
    incorrectly.Only a static class method or function
    can be used in a uninstall hook. Please see <a
    href="http://codex.wordpress.org/Debugging_in WordPress">Debuggi
    ng in WordPress for more information. (This message was added
    in version 3.1.) in
    <b>C:\Xampp\htdocs\wordpress\wp-includes\funktions.php</b> on
    line <b>2959</b>

    <b>Notice</b>: Use of undefined constant wp_cumulus_widget -
    assumed 'wp_cumulus_widget' in
    <b>C:\Xampp\htdocs\wordpress\wp-content\plugins\wp-cumulus\w
    p-cumulus.php</b> on line <b>375</b>

    <b>Notice</b>: register_sidebar_widget ist seit Version 2.8
    veraltet! Benutze stattdessen
    wp_register_sidebar_widget(). in
    <b>C:\Xampp\htdocs\wordpress\wp-includes\funktions.php</b> on
    line <b>2839</b>

    <b>Notice</b>: register_widget_control ist seit Version 2.8
    veraltet! Benutze stattdessen
    wp_register_widget_control(). in
    <b>C:\Xampp\htdocs\wordpress\wp-includes\funktions.php</b> on
    line <b>2839</b>

    <b>Notice</b>: Undefined index: page in
    <b>C:\Xampp\htdocs\wordpress\wp-content\plugins\header-footer\p
    lugin.php</b> on line <b>60</b>

    ----------------------------------------------------------

    error message II
    The server returned unexpected output

    <b>Notice</b>: register_uninstall_hook was called
    incorrectly.Only a static class method or function
    can be used in a uninstall hook. Please see <a
    href="http://codex.wordpress.org/Debugging_in WordPress">Debuggi
    ng in WordPress for more information. (This message was added
    in version 3.1.) in
    <b>C:\Xampp\htdocs\wordpress\wp-includes\funktions.php</b> on
    line <b>2959</b>

  11. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    All the messages are from other plugins than wppa+.

    Remove define('WP_DEBUG', true); from wp-config.php, this will help.

    If there are still errors, find out what plugin, and report there.

  12. patsch27
    Member
    Posted 2 years ago #

    Hello,

    meantime the website from localhost moved to the server.
    Although the same data, the error is no longer present.
    The changes affect only the paths in the MySQL and wp-config.

    However, on the localhost is the error.
    There helps no deactivation all plugins, or reinstall WPPA etc.

    But is not a problem as long as ok on the server.
    Localhost is only a test version.

    THX
    patsch27

  13. bsweeting
    Member
    Posted 2 years ago #

    Warning: Wrong parameter count for strtolower() in /home/bobbieys/public_html/wp-content/plugins/wp-photo-album-plus/wppa-album-admin-autosave.php on line 627

    I am still getting this error..need help

  14. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    You found a bug.
    The line 627 reads:

    $seq[] = strtolower(wppa_get_album_name($album['a_parent']), 'extended');

    Change to:

    $seq[] = strtolower(wppa_get_album_name($album['a_parent'], 'extended'));

    or select a different column to sort

  15. bsweeting
    Member
    Posted 2 years ago #

    where do I find this to correct it

  16. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    /wp-content/plugins/wp-photo-album-plus/wppa-album-admin-autosave.php

    go to the plugins page, scroll down to WP Photo Album Plus press Edit, open wppa-album-admin-autosave.php, find the line, change the ) and save, done!

    Or wait for the next release

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Photo Album Plus
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic