Support » Plugin: WP Photo Album Plus » [Plugin: WP Photo Album Plus] 2.5.0 install issue

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    What is your servers php version?

    pls verify that line 99 of wppa_export.php reads as follows:

    if ($wppa_zip->open($zipfile, ZipArchive::CREATE) === TRUE) {

    For the time being you can go back to version 2.4.4
    you can download it here

    I can’t seem to find php version, sorry, I am using a web interface for the install and only have ftp/web access to the server, no shell access.

    That is exactly what line 99 of the file has here.

    In the meantime, I’ll go back to 2.4.4.

    Thanks!

    According to the machine’s owner, we’re using
    PHP 4.3.9-3.22.3

    FYI: 2.4.4 re-install is working fine.

    Thanks!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Some plugin or theme (re)defines CREATE that caused the error. I patched the code to avoid this conflict (the code i used comes straight from the PHP manual) by replacing ZipArchive::CREATE by its value, being 1.

    So, you can now safely upgrade to 2.5.0, either automatic or ‘by hand’ as long as you use the current uploaded version. This has already been done by another user that had the same problem.

    After upgrade, you will see your php version at the top of the Photo Albums -> Settings screen.

    Good luck!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: WP Photo Album Plus] 2.5.0 install issue’ is closed to new replies.